Support » Plugin: Subscribe To Comments Reloaded » How to reposition Subscribe to Comment box

  • Below is the current order of Comment Form elements:
    Comment
    Name
    Email
    Website
    RECAPTCHA Plugin
    Checkbox to subscribe to Mailchimp distribution
    Subscribe to Comments Reloaded
    Post Comment Button

    I would like to reposition Subscribe to Comments Reloaded below “Website” and above the RECAPTCHA Plugin. How do I rearrange the order?

    Any help is appreciated. Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author WPKube

    (@wpkube)

    Hi @mikee68

    There’s no option to reorder at the moment, can you send over the website URL, might be able to write up some CSS code to change the order.

    Thread Starter mikee68

    (@mikee68)

    Hi WPKube,

    Thanks for your reply.

    Link to my website and post: https://cashflowplayground.com/coming-soon/

    I would like the “Replies to my comments” box be the first element after the comment, name, email, website fields…before the “save my name…” checkbox and before RECAPTCHA and MC4WP plugins.

    Another issue after I wrote the original forum post:

    The “Save my name, email, and website in this browser for the next time I comment.” text is not inline with the checkbox. Anyway to line them up?

    Thanks for helping to resolve the issues.

    Plugin Author WPKube

    (@wpkube)

    Hi @mikee68

    Try this (goes in WP admin > Appearance > Customize > Additional CSS):

    #respond form {
     display: flex;
     flex-direction: column;
    }
    
    #respond form > * {
     order: 1;
    }
    
    #respond form > .anr_captcha_field {
     order: 2;
    }
    
    #respond form > .mc4wp-checkbox {
     order: 3;
     margin-top: 20px;
    }
    
    #respond form > .form-submit {
     order: 5;
    }
    Thread Starter mikee68

    (@mikee68)

    WPKUBE:

    I copied and pasted the code you sent into Additional CSS and there is no change to the order or anything. Any other ideas?

    – Mike

    Plugin Author WPKube

    (@wpkube)

    Hi @mikee68

    This is a bit weird, I see the CSS in there but it doesn’t apply for some reason.

    Might be related to the Customizer CSS not being served the usual way inside of style tags but instead it’s external and something goes wrong with encoding blank spaces.

    Are you using any plugin for that purpose?

    Try the following code (remove the one from before).

    #respond form {display:flex;flex-direction:column;}
    #respond form > * {order:1;}
    #respond form > .anr_captcha_field {order:2;}
    #respond form > .mc4wp-checkbox {order:3;margin-top:20px;}
    #respond form > .form-submit {order:5;}
    Thread Starter mikee68

    (@mikee68)

    WPKube:

    That worked!! Prefect! Thanks!

    The bad news is I detected a major PRIVACY breach:

    Upon receiving a “There is a new comment…” email, when you click on “One click unsubscribe” in the email it takes you to the “Manage subscriptions” page whereby it displays ALL SUBSCRIBERS’ EMAIL ADDRESSES! I even uninstalled and reinstalled the plugin thinking maybe mine got contaminated somehow, and it still displays all email addresses. Further testing, I created a fake email address and manually added new subscription inside the StCR plugin, and it still displayed all addresses (including the fake one) when ANY subscriber clicks “One click unsubscribe”.

    Needless to say this needs immediate attention as I would assume this breach applies to everyone using the plugin. Please investigate and let me know what you discover. Thank you.

    – Mike

    Plugin Author WPKube

    (@wpkube)

    Hi @mikee68

    Are you logged in as the administrator when you’re on that page?

    The “manage subscriptions” page shows all the subscriptions to administrators.

    For regular visitors it only shows the subscriptions specific to that one email address.

    Thread Starter mikee68

    (@mikee68)

    You are correct. Sorry for the panicked email. It was just strange how when clicking “manage subscriptions” it showed only that email addresses subscriptions, yet clicking “one click unsubscribe” it showed all addresses.

    Thanks again for the code to reorder comment elements!

    Plugin Author WPKube

    (@wpkube)

    Hi @mikee68

    No worries. We’ll probably add a little text box in there that shows for administrators explaining why all the subscriptions are shown.

    You’re welcome, happy to hear it worked out.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘How to reposition Subscribe to Comment box’ is closed to new replies.