Support » Fixing WordPress » How to repair database that's causing saving issues?

  • Hello all, I’m really hoping someone here can help me. I’ve got a website that was working fine with a large Woo Commerce shopping cart. The site was running slowly, however, and the web host suggested I optimize the database. So, I ran the WP-Optimize plugin and it indeed saved some space but didn’t seemingly help the speed issue.

    The next day Woo Commerce started having problems. You could add a new product and attach a “previously created” attribute or variation, but as soon as you attempted to create a “new” variation or attribute, it wouldn’t save it to the product. I contacted Woo and they sent me a list of server mods they suggested my web host make, citing that perhaps the data submission size was too small and couldn’t save all the variations. The host made the mods. At that point there was some could add ONE variation to a product, but as soon as you added TWO variation, it only saved the most recent one you added and deleted the first one. So, the probably wzs still there, just in a different form. Woo then asked me to upgrade to the most recent version of their plugin, that this “Saving” issue was indeed a bug that had been fixed in the most recent version. So, I upgraded Woo. Still had the same problem.

    Then it was suggested I turn on and off all the plugins and try saving a product variation with each one turned off. That did not work either. So, I tackled it form a different angle…I installed a fresh copy of WordPress 3.5.1, a fresh copy of Woo 1.6.6, and the problem was fixed. I added in each plugin that was on the original site, one by one, and I was fine. However, as SOON as I imported in the database from the site, with all the products in it, the problem began to happen again.

    Since this issue began right after I optimized the database, I asked both Woo and the web host if the optimizer could have caused the issue and they said no. However, it’s the database itself that seems to have the issue, and there were no problems until AFTER I ran that optimizer. So, my question is…how do I fix this? I am not a tech person and I’ve been following the suggestions of the web host and Woo and it appears neither is the problem.

    So, could the optimizer have done this? And how do I fix it? Any help would be SO appreciated. I would even be happy to pay someone to look at it and fix it for me. I am at my wit’s end on how to solve this problem.

    Thank you for reading.

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘How to repair database that's causing saving issues?’ is closed to new replies.