Support » Plugin: Yoast SEO » How to remove the page title from the website homepage title on the web browser?

  • Resolved Indike

    (@minus43)


    When you place cursor on the browser tab, it shows “home-foodquizzer” I don’t want to show the “home” there, just the site title and the tagline.
    I have defined it on the wordpress settings>general but still it shows the same. Can someone please show me how exactly to change it? Thanks.

    I asked this on the WP forum and they directed me here as I’m using the Yoast plugin. I tried with all options on-page but still the problem is there. Can anyone help me please? What setting should I exactly change?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support devnihil

    (@devnihil)

    @minus43 We’re sorry to hear you are experiencing this issue on your site.

    To set the Title for your page you would need to perform the following actions:

      • In WordPress, go to the Edit screen for a page/post
      • Scroll down to the Yoast Metabox
      • Input a value for ‘SEO Title’
      • Click ‘Update’ to save the changes to the page/post

    We also have a guide on editing the Title settings for Yoast SEO located here: https://yoast.com/wordpress/plugins/seo/titles-and-meta-descriptions/

    Can you please try the aforementioned suggestions and let us know whether this resolves your issue?

    Thread Starter Indike

    (@minus43)

    @devnihil
    Yes it worked! You are a life saver. Thank you so much for this help it means a lot to me. I clicked “insert variable” and selected “%%sitename%% %%sep%% %%sitedesc%% ” (site title, separater, tagline)
    Now it is just as I wanted. Thanks a lot.

    • This reply was modified 1 year, 5 months ago by Indike.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘How to remove the page title from the website homepage title on the web browser?’ is closed to new replies.