Support » Fixing WordPress » How to remove the page name from the website homepage title on the web browser?

  • When you place cursor on the browser tab, it shows “home-foodquizzer” I don’t want to show the “home” there, just the site title and the tagline.
    I have defined it on the wordpress settings>general but still it shows the same. Can someone please show me how exactly to change it? Thanks.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • You’re using the Yoast SEO plugin, which (usually) controls this (ie HTML titles).

    You’re also using a “static” page for your homepage (instead of displaying the latest posts).

    Open this page that you’ve designated as your homepage. You should have the Yoast SEO options at the bottom of the editor, where you can customise the automatically-generated title text, add meta description text, etc.

    If you don’t find the Yoast SEO customization option in the editor, please ask for help in the Yoast SEO plugin’s own support forum so the plugin’s developers and user community can help you out.

    Please see: https://wordpress.org/support/plugin/wordpress-seo/

    Good luck!

    Thread Starter Indike

    (@minus43)

    Thanks George I tried there but I cannot find any setting to change it on Yoast on-page settings. I posted the question on the forum you recommended too. This is really frustrating that there’s no easy solution to this.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘How to remove the page name from the website homepage title on the web browser?’ is closed to new replies.