WordPress.org

Support

Support » Plugins and Hacks » Show Hide Author » how to remove the "by" word

how to remove the "by" word

Viewing 15 replies - 1 through 15 (of 23 total)
  • Can you please share with me your theme’s name or even better a link to your website? If you want send them by email.

    Thank you

    Hi I downloaded your plugin but Im left with a “dash” symbol after the date. How to remove that please? I do not know coding so can you please explain in a simple way? My theme is wp-clearphoto and site: http://www.euro-freelancers.eu

    Hello speed101,
    I just updated the plugin to support your theme too. Please install the updated plugin and let me know if it works.

    Thank you. I installed the update but it is still the same. I cleared the cache and refreshed several times but still it does not work. What else could I do?

    It would help me a lot if you could give me access to the admin page of your wordpress website. My email is: m.spyratos@gmail.com

    Thank you for your great plugin. I’m having the same issue with the “by” still showing. I’ve read your instructions but I know little to nothing about using code. I’m using the current version of Weaver II Pro. Here’s a link to a post on the site with the “by” visible:

    Hello chris8008.

    I don’t see the link. Try this:
    Go to show hide author settings page and near the bottom of the page you will find the section “Advanced: Hide the “by” word”.

    Fill in the following:

    The parent classes: by-author
    The regular expressions: <span class=”sep”(.*?)/span>

    This will remove the line <span class="sep"> by </span> from inside the span with class by-author, as shown here:

    <span class="by-author">
    <span class="sep"> by </span>
    <span class="author vcard">...</span>
    </span>

    I entered those two lines in the two fields:
    The parent classes: by-author
    The regular expressions: <span class=”sep”(.*?)/span>

    And it got rid of the by in the posted by line. There’s still a by in the category line: This entry was posted in (category) by

    Sorry. My link didn’t post last time. I’ll just paste it in this time without trying to make it a live link:
    http://cmacneil.com/art/2005/05/23/red-house-no-18/

    Oh. Ok!
    Then add these values:

    The parent classes: by-author;entry-utility
    The regular expressions: <span class=”sep”(.*?)/span>;by <a(.*?)/a>

    That worked great. Thanks so much!

    Hi,
    Thanks for a cool plugin. It works as advertised, but when I activate it, I’m left with a period after the post date. I tried following your instructions, but can’t seem to work it out. Here is, I think, the relevant code:

    ——————————
    <div class=”entry-meta”>
    <?php echo retina_post_date() . retina_post_comments() . retina_post_author() . retina_post_sticky() . retina_post_edit_link(); ?>
    </div><!– .entry-meta –>
    ——————————

    What should I place in the parent class and regex fields of your plugin to get rid of the period?

    Thanks a lot.

    Hello!

    I can’t help you with the code you provided.
    Please let me know the name of the theme that you are using and/or a link to your website.

    You could try to open the functions.php file in your theme’s folder and search for retina_post_date. Probably you will find the text that you need to remove…

    Thank you for the response.

    This is the theme:
    http://wordpress.org/themes/retina

    And my site is at capefearreview.com

    Thanks for your help.

    Ok… So here is the HTML on your website:

    <div class="entry-meta">
       <span title="August 31, 2013 6:13 am" class="entry-date">
          <a rel="bookmark" title="Pepper Pot" href="http://capefearreview.com/?p=31">August 31, 2013 6:13 am</a><br />
       </span>
       <span class="entry-meta-sep"> ⋅ </span>
       <span class="entry-author author vcard">
          <a rel="author" title="by " href=""></a>
       </span>
    </div>

    So to remove the dot, go to the plugin settings and add near the bottom:

    The classes: entry-meta
    The regular: <span class="entry-meta-sep"(.*?)/span>

    I still can’t get it to work. I did notice that the dot isn’t actually a period–it’s in the middle, rather than at the bottom. I tried just copy-pasting it in place of the period in your code, but no dice. Is it because it’s a special character? Also, are the spaces important?

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘how to remove the "by" word’ is closed to new replies.
Skip to toolbar