WordPress.org

Forums

WooCommerce - excelling eCommerce
[resolved] How to remove "my account" from menu. (18 posts)

  1. Cparker32
    Member
    Posted 1 year ago #

    Unable to remove "my account" from menu. It's not located in the wordpress menu section. I also checked Woocommerce -> Settings -> Pages and there is no option to remove - the "Append a logout link to menus containing My Account" is no where to be found either.

    How do I remove "my account" from the menu?

    http://wordpress.org/plugins/woocommerce/

  2. Delirium Comics
    Member
    Posted 1 year ago #

    I don't entirely follow what your saying but if it's what I think then go to Appearance > Menus. There you will see all the pages and liks that make up your site menu.

    Click the little arrow on the "My Account" part and it will expand the menu item. Click remove than save the menu.

    I'll hazard a guess that you also have "Automatically add new top-level pages to this menu" checked under menu settings. You might want to uncheck that.

  3. kenniswong1977
    Member
    Posted 1 year ago #

    I have the same problem. After installing Woocommerce, the "My Account" menu option is automatically added to the top menu.

    I am running an affiliate store, so there's no need to have "My Account".

    "My Account" is not found on the menu option (under Appearance -> Menus). It's like somehow it's hardcoded and bypass what I specified in the Menus section.

    Anyone solved this problem?

  4. kenniswong1977
    Member
    Posted 1 year ago #

    And "Automatically add new top-level pages to this menu" is NOT checked in my setting.

  5. Roy Ho
    Member
    Posted 1 year ago #

    WP by default picks up all pages to be in the menu as a fallback. Only when you start to use the WP menus is when you can customize what is shown and what is not.

    So I suspect you all are not using the WP menus. Another words if you go to Appearance->Menus, it is blank or not assigned to anything.

  6. Delirium Comics
    Member
    Posted 1 year ago #

    hmm... Well then, maybe if you go into the Woo settings Pages area you can unset the My Account page. If that doesn't solve your issues... /shrug.

  7. Cparker32
    Member
    Posted 1 year ago #

    Re-read my original post.

    It is not listed in WordPress > Appearance > Menus.
    The page is only listed in the Woocommerce page setup and can not be removed.

    I explained both points in original post.

  8. Cparker32
    Member
    Posted 1 year ago #

    Luckily my theme has an option to turn it off (it was a common complaint on their forum and they included it in their theme).

    However, others still have this issue and need assistance.

    This is not a wordpress issue. It's an issue with Woocommerce plugin.

  9. Roy Ho
    Member
    Posted 1 year ago #

    Then good luck to you as I don't have any issues with it on my sites...

  10. Delirium Comics
    Member
    Posted 1 year ago #

    I'm not certain it's a WooCommerce issue per se. I'm not sure why you can't unset it in your WooCommerce, I can.

    If anything I'd say it's a theme issue. What theme are you using?

  11. Cparker32
    Member
    Posted 1 year ago #

    Avada. Avada has an option to disable it from there theme options. So, I guess it could be a theme option. I spent hours searching online for an answer before I found it on their forum.

  12. kenniswong1977
    Member
    Posted 1 year ago #

    Cparker32, you are my hero. Just so happen that I am also using Avada and I found it in Theme option!! Thank you!

  13. ozbassplayer
    Member
    Posted 1 year ago #

    Cheers Cparker32. Like kenniswong1977 I'm also using Avada and needed this solution.
    Thankfully I spent only 3 minutes finding the solution here.
    Cheers, I owe ya a beer!

  14. Rob
    Member
    Posted 1 year ago #

    Duplicate post! Mods please delete...

  15. Rob
    Member
    Posted 1 year ago #

    This seems like a common one but not a lot of answers! Here's how I did it on for my replacement toothbrush battery site at toothbrushbattery.com

    You can use this to remove any pages you don't want, not just the Account page. You can also use it to create a custom blank homepage without the title in the middle of it and also a blog page.

    • In your WP dashboard under Appearance, Menus click to create a new menu.
    • Give the menu a name and add in all the pages you do want to appear in your menu.
    • Importantly, underneath in the Menu Settings set it as the Primary Menu under Theme Locations.
    • Save your menu and that should be it!

    Rob

  16. Rob
    Member
    Posted 1 year ago #

    PS This works for the free Mystile Woocommerce theme.

  17. Coen Jacobs
    Member
    Posted 1 year ago #

    As explained a couple times in this topic already, this is default WordPress behaviour and has nothing to do with WooCommerce. WordPress defaults to adding all top level pages to the main menu if you haven't specified one.

  18. chalacatepec
    Member
    Posted 11 months ago #

    This is the closest thread I have found but the info does not help me. I switched themes from Marketer to Make. Now on my WP dashboard a small screen pops up when I try to go to the help and screen options. This window has an email address,edit my profile and log out. I can not find a way to remove this. this screen stops me from being able to use the help option and I need all the help I can get.It must be an easy fix if you know where to go. Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.