WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] How to remove "meta robots = no-index" from blog?

[Resolved] How to remove "meta robots = no-index" from blog?

  • upwords

    @upwords

    I have a blog (www.upwordsranking.com) that is not indexed in search-engines, the pages have a meta robots = “no index” setting despite (obviously) having set the “privacy” option to “visible to everyone.” I have a default sidebar with a “no-index” setting (to avoid duplicate content), this shouldn’t effect the whole blog, but maybe this is the problem? Any suggestions?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Joseph

    @jpe24524

    Check the keyword-statistics-plugin. This is from your page source.

    <!-- metadata inserted by keyword-statistics-plugin 1.7.5 http://www.keyword-statistics.net -->
    <meta name="keywords" content="content,search,seo,business,online,site,engine,media" />
    <meta name="robots" content="noindex,follow,noodp,noarchive,noydir" />
    <link rel="canonical" href="http://www.upwordsranking.com/" />
    <!-- end of metadata -->

    upwords

    @upwords

    hi Joseph, thanks for the tip! I did delete the plug-in but it seems I’m still stuck with “no index” as well as “no follow” (on all links), it’s as if there is a default “shut-down” on all movement to and through the blog… 🙁

    Joseph

    @jpe24524

    Found this in your sidebar:

    <html>
    <head>
    <title>...</title>
    <meta name="robots" content="noindex, nofollow">
    </head>
    
    <strong>Upwords Ranking </strong>is not a company in the traditional sense; there are neither offices nor an employer/employee structure. We are a constellation of SEO consultants, writers, animators and small companies working on a project-to-project basis. This allows us offering lower prices on our services, and to have the flexibility to adjust our strategy to the specific needs of each client.
    
    Contact: info@upwordsranking.com
    </html>

    Is this the no-index setting you’ve mentioned? It’s invalid html as well.

    upwords

    @upwords

    hi,thanks for looking into this. I set a no-follow myself on the sidebar (to avoid dupliacte content issues), but it shouldn’t effect the other pages (nor links), but I guess I should remove this sidebar as well, and start over to see if I can “unlock” the pages…?

    upwords

    @upwords

    ok, that did the trick, the “meta robot” plug-in caused “no-index” on all pages, not just the sidebar!
    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] How to remove "meta robots = no-index" from blog?’ is closed to new replies.
Skip to toolbar