Support » Theme: Twenty Seventeen » How to remove link underline from images in image gallery

  • Resolved millennial1

    (@millennial1)


    Hi there,

    I’m having an issue that I’m struggling to fix on my own. I’m sure it’s simple, but for the moment the solution escapes me. I’ve tried searching but haven’t had any luck. I’m using a twenty-seventeen child theme. I also tried setting the default unmodified twenty-seventeen theme so it doesn’t seem theme-related. I don’t discard it possibly being plugin related, though regardless I’d prefer to solve the issue via CSS.

    The issue – When using a tiled image gallery with the images set to links, behind the images there is a black underline as is typical with any class “a” links. I believe I’m using JetPack’s tiled image galleries.

    In the link below it can be seen behind the two images. At the middle at both sides of the image. If you position the cursor over the image it will trigger the “a:hover” action.

    I haven’t found how to remove it without removing the underlining of all links (including text link). What I’d want is simply to remove the underlining for images that have links.

    If anyone has any suggestions or any other information is needed, please let me know. It’s kinda bugging me to see that black line.

    • This topic was modified 1 year, 9 months ago by millennial1.
    • This topic was modified 1 year, 9 months ago by Andrew Nevins.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    In the “Additional CSS” section of the dashboard add this:

    
    .tiled-gallery-item a,
    .tiled-gallery-item a:hover,
    .tiled-gallery-item a:focus {
        box-shadow: none;
    }
    

    https://codex.wordpress.org/CSS#Custom_CSS_in_WordPress

    Thanks Andrew! That looks like it works great!

    After playing around with it a little longer, I finally confirmed it was JetPack’s fault, as it was overriding the default box-shadow code:

    .entry-content a img, .comment-content a img, .widget a img {
        -webkit-box-shadow: 0 0 0 8px #fff;
        box-shadow: 0 0 0 8px #fff;
    }

    I found that I could also solve it assigning it the !important tag, but I guess that’s just lazy coding. I imagine your solution is more “correct”.

    Anyway, I really appreciate it. I’ll sleep better tonight thanks to you 😉

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘How to remove link underline from images in image gallery’ is closed to new replies.