Support » Fixing WordPress » How to remove comment box from a page

  • Hello,

    On this page:

    I would like to remove the comment box. As you will see, it is going to be a questionaire and so the normal comment box is superfluous. Have tried changing the template type but that doesn’t seem to address the issue. Apologies if answer is obvious – early part of learning curve!

    Andrew C.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Michael


    Forum Moderator

    on the ‘edit page’ page, you should have the options to stop comments, below the page editor, a box ‘discussion’ –
    if that is not there, click the ‘screen options’ tab near the top right of that page, and tick the appropriate tick box.

    at the moment you even have a text pointing to the comment box:
    ‘Any other general comments may be entered in the box below. Thank you for taking the time to help with this consultation. ‘

    Hi alchymyth,

    Thanks for reponding so quickly. Maybe i’m not looking at things correctly.
    From the screen options, comments is unchecked. I’ve looked at ‘discussion’ under settings. Doesn’t that apply to all pages, rather then just the page being edited?

    Yes, i realize that there is the explanatory text above the coment box. Put that in as i couldn’t find out how to get rid of the box. But it really needs to go as two submit buttons on one page will be a problem.
    Have to go out now, will look again at the issur later. your help is much appreciated. My grey cells are slower than usual today….

    Andrew C.

    Confirm resolved.

    quickedit > uncheck ‘allow comments’

    Don’t know how I missed that – think a period away from PC was needed….

    Andrew C.

    Sorry for jumping in on this thread but . . . I have had a problem where on a 2 page site: The front page is a static page that used to have the Comment box at the bottom – Thank you Alchymyth for instructing me how to remove this. The second page is my blog page. I have comments allowed. There is a link that says “Leave a Comment” which is fine. The problem comes in when you click on this link, it navigates to the home page, (where the Comments box used to be). How do I get the comments box to open below the blog post?

    I would also like to remove all comments boxes from my website ( and have unchecked ‘allow comments’ in the ‘discussion’ section under ‘settings’. I have also gone to the ‘screen options’ on individual pages and unchecked ‘discussion’ and ‘comments’ there. However, the ‘leave a reply’ box still appears at the bottom of every page.
    Also several people have mentioned that you have to edit the php of the page. Can someone tell me how I do that?


    In dashboard, go to posts > post to be altered > quick edit.

    You will see a check box for ‘allow comments’. Uncheck the box.

    Andrew C.

    Thanks Andrew, that worked perfectly.



    Hi I am just trying to build a website with WordPress Twenty Ten and I also cannot seem to get rid of the comment box at the bottom of each page. I have tried all the suggestions in this thread without success. I am sure that I am missing something obvious. I want to be able to create the structure and then get people in the various churches to edit their own pages. To start with I think we would not want comments – maybe later on. Any ideas. The trial site is at



    Hi Neil,

    So you have been to: posts>post to be altered>quick edit – uncheck the’allow posts’ box?

    That seems to work for me with the 2011 theme, and used to work the same when I had 2010 loaded. Regret cannot suggest anything else, hopefully someone more experienced will chime in here…



    Hi Andrew, thanks for replying. When I click on Posts I get four choices
    All Posts
    Add New
    I cannot find ‘posts to be altered>quick edit.
    I have unchecked the comments box in every place that I have found it but I still get a reply form at the bottom of every page. There is very little content yet on the site – and no posts. I am using it as a website primarily for our 6 churches and trying to get it as user friendly as possible before getting others on board to supply the content. There must be something obvious I have missed. I really like the nice clean lines and simple navigation of the site you mention above. Neil



    Hi again – I have just discovered what I have to do. On each page the Quick Edit does indeed have a comments box allow checkbox. Problem solved. Many thanks. Neil



    Heyy Guyz,I’ve successfully removed my comment box on my website.
    if you want to remove your comment box then follow these steps on this link:

    Works 100%

    I couldn’t find it either, until I looked in Quick Edit. IMHO, seems like the regular edit should have all of the things that the quick edit has. Nice to have it figured out in any case.

    Hi Mike,

    Yes, agreed. I too thought that ‘edit’ would have everything, and ‘quick edit’ an abridged version. Still, no great problem once discovered…

    Chip Bennett


    Theme Review Admin

    Dear all:

    If your issue does not exactly correspond to the original poster’s issue, then you need to start your own support topics. Posting issues and solutions unrelated to the OP’s topic is both considered extremely inconsiderate, and also dilutes the ability of future users to find specific answers/solutions for specific questions/issues.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘How to remove comment box from a page’ is closed to new replies.