Support » Plugin: Jetpack by WordPress.com » How to remove all comment subscribers?

  • Resolved MarkRH

    (@markrh)


    I tried to test out the Jetpack comment subscription which I’ve had active for a long time and no email was sent to my test accounts this time (no Errors). So, I decided to see if I could just removed all of the email comment subscribers and I see no way to do this.

    How do I remove these: https://i.imgur.com/xAWwOPr.png

    Don’t know if it’s related but I see a lot of the following in my Apache access logs:

    
    192.0.87.36
    	
    3/20/19, 11:56 PM
    	
    error 402
    	
    /xmlrpc.php?for=jetpack&token=(stuff)&timestamp=1553140596&nonce=hDZPsLsUTO&body-hash=(stuff2)&signature=(stuff3)
    

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Well, I made a new test comment and selected the option to receive email follow-ups and then I replied to it with my main account and that did work. When I got the confirmation email on my test account, it did show the other post it was subscribed to and deleted it.

    Anyway, that account did get an email reply to the new comment. Is there a time limit where it stops sending email alerts on old posts? Or, are these previous subscriptions just all broken.

    Plugin Support KokkieH

    (@kokkieh)

    Hi there,

    It’s not possible for you as site owner to remove comment followers. Jetpack subscriptions for both posts and comments are controlled by the subscriber themselves, so if a particular subscriber no longer wants to receive notifications, they need to unsubscribe themselves, either via the Unsubscribe link in a notification email, or else by visiting https://subscribe.wordpress.com and entering the email address they’d used to subscribe.

    So if you have different test subscriptions set up with different emails, you’d need to repeat this process for each email address. Make sure that you’re not logged into your WordPress.com account when doing this, else the link you’ll receive from subscribe.wordpress.com will just take you back to your WordPress.com account.

    Is there a time limit where it stops sending email alerts on old posts? Or, are these previous subscriptions just all broken.

    There’s no time limit that I know of, no. If you’re subscribed to a post, you should receive notifications of new comments no matter how old the post is.

    But it looks like there’s a sync issue on your site – we’re not able to sync data from your site to our servers, so we have no way of knowing when a comment is made so we can send a notification to subscribers.

    When Jetpack tries to make a request your server returns the 402 which is actually not a clear indicator of anything. Can you ask your host to check the server logs to see what’s generating the 402 error message?

    Alright, the 402 errors are generated when I go to wordpress.com stats site for my blog. https://wordpress.com/stats/day/7166605 in this case. It has information there so it is getting something back.

    The raw Apache access logs then contain:

    
    (my ip) - - [21/Mar/2019:05:39:53 -0400] "POST /wp-admin/admin.php?page=stats&noheader&chart=flot-stats-data HTTP/2.0" 200 3289 "(my blog)/wp-admin/admin.php?page=stats" "Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0"
    
    192.0.89.65 - - [21/Mar/2019:05:40:06 -0400] "POST /xmlrpc.php?for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161206&nonce=ipTebvA1Jr&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=wRvQIXpM9qCJher%2BAs9vIANFumk%3D HTTP/1.1" 402 1 "(my blog)/xmlrpc.php?for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161206&nonce=ipTebvA1Jr&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=wRvQIXpM9qCJher%2BAs9vIANFumk%3D" "Jetpack by WordPress.com"
    
    192.0.87.13 - - [21/Mar/2019:05:40:06 -0400] "POST /xmlrpc.php?for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161206&nonce=bjZlK3hkO3&body-hash=pdst%2B%2B8gjpsEsdzTGdS19%2BYN3g4%3D&signature=vqcPU3kHhpZvzfn6Fm5bmm0s%2FeY%3D HTTP/1.1" 200 131 "(my blog)/xmlrpc.php?for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161206&nonce=bjZlK3hkO3&body-hash=pdst%2B%2B8gjpsEsdzTGdS19%2BYN3g4%3D&signature=vqcPU3kHhpZvzfn6Fm5bmm0s%2FeY%3D" "Jetpack by WordPress.com"
    
    192.0.87.18 - - [21/Mar/2019:05:40:06 -0400] "GET /?rest_route=%2Fjetpack%2Fv4%2Fjitm&message_path=calypso%3Astats%3Aadmin_notices&_for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161206&nonce=ANRSIvmUbt&body-hash&signature=B2a1CgjVn4iVKaBwEDeCfYQaFFY%3D HTTP/1.1" 200 2 "(my blog)/?rest_route=%2Fjetpack%2Fv4%2Fjitm&message_path=calypso%3Astats%3Aadmin_notices&_for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161206&nonce=ANRSIvmUbt&body-hash&signature=B2a1CgjVn4iVKaBwEDeCfYQaFFY%3D" "Jetpack by WordPress.com"
    
    192.0.89.57 - - [21/Mar/2019:05:40:08 -0400] "POST /xmlrpc.php?for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161208&nonce=gjGVtSljcp&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=b4FBb95naYD2q1U7nzjegDq6qHg%3D HTTP/1.1" 402 1 "(my blog)/xmlrpc.php?for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161208&nonce=gjGVtSljcp&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=b4FBb95naYD2q1U7nzjegDq6qHg%3D" "Jetpack by WordPress.com"
    
    192.0.87.116 - - [21/Mar/2019:05:40:13 -0400] "POST /xmlrpc.php?for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161213&nonce=H3gAcRMefU&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=TUERCyFJLFjf7GXe2FBbeWuUpTc%3D HTTP/1.1" 402 1 "(my blog)/xmlrpc.php?for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161213&nonce=H3gAcRMefU&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=TUERCyFJLFjf7GXe2FBbeWuUpTc%3D" "Jetpack by WordPress.com"
    
    192.0.87.161 - - [21/Mar/2019:05:40:15 -0400] "POST /xmlrpc.php?for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161215&nonce=GqkmlnXi3q&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=QzInVeCzxGgpLtz7eJG%2FGoyHsW4%3D HTTP/1.1" 402 1 "(my blog)/xmlrpc.php?for=jetpack&token=Nw7%23EHR6zq1oDFfcmax324qz%5EqF%246%2AJi%3A1%3A1&timestamp=1553161215&nonce=GqkmlnXi3q&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=QzInVeCzxGgpLtz7eJG%2FGoyHsW4%3D" "Jetpack by WordPress.com"
    
    
    • This reply was modified 3 months, 1 week ago by  MarkRH.
    Plugin Support KokkieH

    (@kokkieh)

    Okay, we’ve had a look at this, and those errors point to a block on your host’s end as the most likely cause. Please contact them and make sure there’s nothing on that end that’s blocking access to XML-RPC on your site.

    https://jetpack.com/support/getting-started-with-jetpack/fixing-jetpack-connection-issues/#check-xmlrpc-php

    I’m also seeing some whitespace if I view the source for the xmlrpc.php file on your site at view-source:https://blog.markheadrick.com/xmlrpc.php, which could be relevant. That could indicate a plugin or your theme injecting some content into that page, which could lead to connection errors.

    I see you’re using a default theme, Twenty Twelve, so it’s unlikely to be your theme. But check if disabling all other plugins on your site makes any difference, and also check for whitespace in your wp-config.php file.

    Well, I Deactivated Jetpack and Deleted it. Reinstalled with all other plugins disabled and reconnected fine. My Jetpack Dashboard isn’t empty now so that part got fixed. I still get the 402 entries when going to https://wordpress.com/stats/insights/blog.markheadrick.com though. But, the information is populated. At least one of the calls to xmlrpc.php has a 200 response.

    But even though it is generating the 402 calls, it is sending out emails to my test accounts now when adding new comments to a test post.

    Plugin Support KokkieH

    (@kokkieh)

    It appears that when you reconnected we were able to at least partially sync with your site, but I’m still seeing 402 errors on our end.

    Something has changed, though – when I now check your site in our XML-RPC validation service as explained in the support doc I provided above, I get a 403 Forbidden error, rather than the 402 error from before. I also see a 403 error when I try to view your site’s xmlrpc.php file at https://blog.markheadrick.com/xmlrpc.php, where previously I could see it.

    This supports the hypothesis that the problem is with XML-RPC being blocked on your server.

    Have you checked with your host regarding blocking of XML-RPC? Or if you’re running your own server, make sure that’s enabled and also check for any ModSecurity rule or similar that could, perhaps unintentionally, be blocking access.

    Yeah, I did block xmlrpc.php myself with

    
    # BEGIN protect xmlrpc.php
    <FilesMatch "xmlrpc\.php">
        Require all denied
        Require ip 127.0.0.1
        Require ip 192.0.64.0/18
    </FilesMatch>
    # END protect xmlrpc.php
    

    That’s been removed. Latest RAW access logs on my end:

    
    192.0.89.63 - - [21/Mar/2019:15:24:34 -0400] "POST /xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196273&nonce=ZLitGUTLdM&body-hash=ZW3qOLsXja6EzZtMuzRflGsRPlk%3D&signature=tFhjd%2Ba%2FBE2JIAdcsVVos5xcX4o%3D HTTP/1.1" 402 1 "(my blog)/xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196273&nonce=ZLitGUTLdM&body-hash=ZW3qOLsXja6EzZtMuzRflGsRPlk%3D&signature=tFhjd%2Ba%2FBE2JIAdcsVVos5xcX4o%3D" "Jetpack by WordPress.com"
    192.0.86.198 - - [21/Mar/2019:15:24:34 -0400] "POST /xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196273&nonce=LbkMNzjFxJ&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=%2F%2FOcVDPO3k5cfKlW5w2kzWroFJw%3D HTTP/1.1" 402 1 "(my blog)/xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196273&nonce=LbkMNzjFxJ&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=%2F%2FOcVDPO3k5cfKlW5w2kzWroFJw%3D" "Jetpack by WordPress.com"
    192.0.87.126 - - [21/Mar/2019:15:24:34 -0400] "POST /xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196273&nonce=ckwY7II8mD&body-hash=pdst%2B%2B8gjpsEsdzTGdS19%2BYN3g4%3D&signature=8L7a%2FnlX0jgKl2ajAAl34z90Y%2B8%3D HTTP/1.1" 200 131 "(my blog)/xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196273&nonce=ckwY7II8mD&body-hash=pdst%2B%2B8gjpsEsdzTGdS19%2BYN3g4%3D&signature=8L7a%2FnlX0jgKl2ajAAl34z90Y%2B8%3D" "Jetpack by WordPress.com"
    192.0.85.161 - - [21/Mar/2019:15:24:34 -0400] "GET /?rest_route=%2Fjetpack%2Fv4%2Fjitm&message_path=calypso%3Astats%3Aadmin_notices&_for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196273&nonce=XROLcgWivy&body-hash&signature=jNkDJRMf8gfyR8BvOV6JMafvY3A%3D HTTP/1.1" 200 2 "(my blog)/?rest_route=%2Fjetpack%2Fv4%2Fjitm&message_path=calypso%3Astats%3Aadmin_notices&_for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196273&nonce=XROLcgWivy&body-hash&signature=jNkDJRMf8gfyR8BvOV6JMafvY3A%3D" "Jetpack by WordPress.com"
    192.0.87.40 - - [21/Mar/2019:15:24:39 -0400] "POST /xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196279&nonce=OZ0yEgjORX&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=YDsajRgTDytibtfiAOeOZIR8x90%3D HTTP/1.1" 402 1 "(my blog)/xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196279&nonce=OZ0yEgjORX&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=YDsajRgTDytibtfiAOeOZIR8x90%3D" "Jetpack by WordPress.com"
    192.0.87.124 - - [21/Mar/2019:15:24:42 -0400] "POST /xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196282&nonce=94syiwWGTo&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=Xqlm6i4ZXlcEeoxTBacGpu%2F006A%3D HTTP/1.1" 402 1 "(my blog)/xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196282&nonce=94syiwWGTo&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=Xqlm6i4ZXlcEeoxTBacGpu%2F006A%3D" "Jetpack by WordPress.com"
    192.0.89.65 - - [21/Mar/2019:15:24:44 -0400] "POST /xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196284&nonce=mD587ZCz5W&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=6%2BtIqhQDZS64mCN09oSCTkcOt%2B4%3D HTTP/1.1" 402 1 "(my blog)/xmlrpc.php?for=jetpack&token=jFL3dLyOif5E2k%28ca9WajsYinN%2AQ4%26zj%3A1%3A1&timestamp=1553196284&nonce=mD587ZCz5W&body-hash=l0xwkG0OxqXFStLZOyXXEVdPKNc%3D&signature=6%2BtIqhQDZS64mCN09oSCTkcOt%2B4%3D" "Jetpack by WordPress.com"
    

    Oh, when viewing the source of xmlrpc.php, the white space you see there is probably due to the default style of the browser viewing source code. Right-click on the text and inspect the element.

    The actual code part is within the <pre> tags.

    
    <pre>XML-RPC server accepts POST requests only.</pre>
    
    Plugin Support Karen Attfield

    (@wpkaren)

    Taking a look at the xmlrpc.php file on your site now, a 403 error is still visible: https://blog.markheadrick.com/xmlrpc.php

    It does need to return the following message:

    XML-RPC server accepts POST requests only.

    You can see a working example here:

    http://jetpack.com/xmlrpc.php

    You mentioned you’d removed the block in the .htaccess file – could there be another script running on your site (perhaps via a security plugin) also creating this block? If you do have any security plugins in place I’d recommend deactivating them to see if that helps. Some security plugins require deletion before any scripts are removed though.

    MarkRH

    (@markrh)

    Sorry, I added the block back in since the symptoms were the same with or without it (I’m the one that did it, not something else within wordpress). It seems like emails are working again, even with the 402 errors. If you notice in the raw access logs I posted, not all calls to xmlrpc.php result in a 402.. one is a 200, so wordpress is not being blocked from it.

    Given that the original problem of this post is now working again (sending emails out for comment responses), I am marking as resolved. I’ll open a bug on github if it warrants in the future.

    I’ll look in some past access logs.. I could have been getting these for months without knowing.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.