WordPress.org

Ready to get started?Download WordPress

Forums

Montezuma
How To Remove a Featured Image? (15 posts)

  1. kevinkwalter
    Member
    Posted 12 months ago #

    I don't want images showing up on the main page of my site (www.kevinkwalter.com), but whenever I insert an image into a post, my theme pulls it as the Featured Image. Any way to stop this?

  2. CrouchingBruin
    Member
    Posted 12 months ago #

    If you don't want thumbnail images showing up at all on your blog page, go to Appearance > Montezuma Options > Sub Templates and edit the postformat.php virtual template. Remove the line that reads:

    <?php bfa_thumb( 620, 180, true, '<div class="thumb-shadow"><div class="post-thumb">', '</div></div>' ); ?>

    This is the function which displays the thumbnails.

    Click the Save Changes button.

    By the way, you may want to change your permalinks so they look nicer, i.e., so your URLs look like http://kevinkwalter.com/about-me instead of http://kevinkwalter.com/?page_id=2. Go to Settings > Permalinks.

  3. kevinkwalter
    Member
    Posted 12 months ago #

    Perfect, thank you!

  4. Zaralene
    Member
    Posted 11 months ago #

    Hi, if I adjust the permalinks with a name my whole theme is meesing op. What can I do about that?
    http://creacont.nl/

  5. CrouchingBruin
    Member
    Posted 11 months ago #

    What do you set your permalinks to? And what happens to it, I can't see anything wrong right now, but I think you changed the permalinks back.

  6. Zaralene
    Member
    Posted 11 months ago #

    I changed it back indeed but now put it again on permalinks with postname. http://creacont.nl/

    what happens is that the breadcrumbs are messed up and the submenu as well. Also I get a weird orange line in the footer area.

  7. CrouchingBruin
    Member
    Posted 11 months ago #

    OK, for the breadcrumbs bar, what happened is you added this CSS:

    ol > li {
       list-style-type: decimal;
    }

    That's overriding the list style for the breadcrumbs bar. So add this rule:

    .breadcrumbs ol > li {
       list-style-type: none;
    }

    For the orange line, there's a CSS rule that looks like this:

    #footer {
       border-top: solid 1px #f99734;
       color: #333;
       font-size: 11px;
       line-height: 1.6;
       padding: 25px 0 0;
    }

    It's the border-top property which is causing that orange line. Take that property out if you don't want that line there, or change the values to something else.

  8. CrouchingBruin
    Member
    Posted 11 months ago #

    Oh, and your widgets are also showing square bullets because of this rule:

    ul > li {
       list-style-type: square;
    }

    Add this to remove them:

    .widget ul > li {
       list-style-type: none;
    }
  9. Zaralene
    Member
    Posted 11 months ago #

    Thanks, I am going to fiddle with it :)
    Would you also know how I can move my top menu to the left, just above my breadcrumbs? I can't figure it out, it should be somewhere in the header.php.

  10. CrouchingBruin
    Member
    Posted 11 months ago #

    Read the documentation under Appearance > Montezuma Options > CSS Settings. Basically, you have to remember that Montezuma is based on a 12 column grid, so the COLn classes for the elements on the same row have to add up to 12.

    So when you look at the header.php sub template, you'll see that in the BANNER row, there are two DIVs, the logo-area with a class of COL5 and the nav menu with a class of COL7. What you will need to do is create another row DIV and move the nav menu inside of it. Then give both the logo-area and the nav menu a class of COL12.

    You will also need to add some CSS to change the menu's positioning from absolute to relative:

    #menu1-wrapper {
       position: relative;
    }
  11. Zaralene
    Member
    Posted 11 months ago #

    That is very clear, thanks.
    I now almost changed everything your said before because of the permalinks, but I still get a strange effect on the titles in the widget area. It's like they are cropped or something. How can I change that?

  12. Zaralene
    Member
    Posted 11 months ago #

    And also the submenu (under top menu) still shows a grey thingie. It just appeared there when I changed the permalinks.

  13. CrouchingBruin
    Member
    Posted 11 months ago #

    Hmm, OK, I just noticed you are using a custom CSS plugin instead of editing the virtual CSS files, which is fine, I do the same thing.

    The widget title's aren't cropped; this CSS in your custom CSS plugin has set the font size to 10px, which is very small:

    .widget h1,
    .widget h2,
    .widget h3,
    .widget h4,
    .widget h5,
    .widget h6 {
       font-size: 10px;
       line-height: inherit;
       margin: 0 0 10px;
       text-transform: uppercase;
    }

    Add this CSS to the end of your custom CSS:

    .widget > h3 {
       font-size: 32px;
    }

    Again, for the submenu items, the bullet style was set by this CSS rule:

    ul > li {
       list-style-type: square;
    }

    So we have to override it again for the submenu items. Add this to the end of your custom CSS:

    ul.sub-menu > li {
       list-style-type: none;
    }
  14. Zaralene
    Member
    Posted 11 months ago #

    Thanks, that will help for sure :)

  15. Zaralene
    Member
    Posted 11 months ago #

    I just noticed that I had a custom CSS from another theme that I used before and that still was in the custom CSS part. It messed up everything. I removed that and all seems to work great now. Sometimes the brain needs a reset too right? Haha.

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.