WordPress.org

Forums

Google+ Crossposting
[resolved] How to re-import posts (6 posts)

  1. gfisch2012
    Member
    Posted 1 year ago #

    I found an explanation how it should work.
    Deleting the last_activity_id field with this SQL command
    SELECT * FROM options where option_name = 'g_crossposting_last_activity_id'

    It worked once. But now I would like to do it again to import some more previous posts.
    I deleted all old posts and deleted the id field again.

    But no luck this time. Somhow I cannot re-import.

    Any ideas?
    Thanks
    av

    https://wordpress.org/plugins/g-crossposting/

  2. Sebastian
    Member
    Plugin Author

    Posted 1 year ago #

    The old trick doesn't work anymore. In the past, I only kept track of the lastest post. But it turned out that this was not reliable enough to determine whether a post was already imported.

    Therefore, since a few versions, I keep track of every single post imported.

    If you look at the wp_options table, you will find entries with option names similar to:

    g_crossposting_SOMELONGID

    You would need to delete all those entries to reimport everything. Besides, you also need to issue the old command as it still serves as a backup method.

  3. gfisch2012
    Member
    Posted 1 year ago #

    Hi Sebastian, that is cool. Great tip.
    Just to be absolutely clear. I am not really SQL savvy. I delete all entries manually that look like this g_crossposting_z13nvh2zcrjgxbtlm23ritczom2hxx1vq

    I go through all pages of the table and delete all of them (but nothing else - haha).
    Here is a screenshot what I am thinking I have to delete.

    Thanks for quickly clarifying. Looking forward to re-import everything.
    Little hint. Maybe you can add a "Start new and import everything again" button. I bet many test the functionally first but would like to import more later.

    Regards
    gfisch

  4. gfisch2012
    Member
    Posted 1 year ago #

    Hi Sebastian
    I now did as you suggested and deleted every entry starting with g_crossposting_
    and I also issued the old command, deleted all posts and clicked on Mass Import.

    But no luck. I get doubt 7 entries (posts from about a week) but not more.

    Isn't there a way to delete the complete table, delete the plug-in and start new again?

    Regards
    gfisch

  5. Sebastian
    Member
    Plugin Author

    Posted 1 year ago #

    That sounds a bit strange. Are you sure the older posts are still public? Also, how many posts are you importing? Maybe you limited it to 7?

  6. gfisch2012
    Member
    Posted 1 year ago #

    Hi Sebastian. Problem solved. All imported. Somehow, after a while it worked. Great tip and thank you. All resolved. :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google+ Crossposting
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic