WordPress.org

Forums

Hueman
[resolved] How to prevent ugly excerpts (Crayon Syntax Highlighter) (3 posts)

  1. jessewebdotcom
    Member
    Posted 1 year ago #

    First off - great theme.

    Issue:
    I use Crayon Syntax Highlighter to color format code snippets I post on my website (http://www.jesseweb.com). They look great on the actual posts but look bad as a featured post or excerpts (squished with forced scrollbars, stretches out page).

    Is there a way I can prevent these snippets from appearing in featured posts and excerpts? Perhaps a tag that I can surround the code in that would cause featured posts and excerpts to skip displaying?

    Thanks.

  2. jessewebdotcom
    Member
    Posted 1 year ago #

    For now I just put the following code at the end of content.php (which gives me the result I want but is not the most efficient way):

    <style>.crayon-main, .crayon-toolbar {display:none;}</style>

  3. jessewebdotcom
    Member
    Posted 1 year ago #

    Duh, figured it out - under the Crayon options, just check "Remove Crayons from excerpts"

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic