Support » Plugin: Polylang » How to prevent that Google shows my /en/-domain?

  • Dear all,

    That installation of Polylang worked all fine, but now I am struggling a bit with how Google is indexing the results.

    I would like to prevent that Google shows my /en/-domain in their search engine. I want to make sure Google always shows my regular domain (without the language-directory) wherever a visitor is based and however the browser language.

    Is this an option in the Polylang-plugin or do I need to add a certain no-follow-tag or so?

    I want to do this because 99% of my target population speaks a very specific language (Dutch) and travels around the globe (expats). I want to keep the English translation I have made with Polylang out of the search engines and offer this as optional for 1% of my non Dutch speaking visitors.

    How can I achieve this?

    Big thanks!

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Setting all /en pages to noindex would probably be the quickest way to do this.

    She can do it:

    A less manual approach would be to serve different robots.txt files depending on the directory visited, one disallowing indexing and the other one allowing it. There’s tons of information on that out there, here’s one of many starting points:

    Thread Starter niekrosens


    Thanks for the reply. The thing is that the webpage is an one-pager, so there is no specific page I can set to “no-index”.

    Is there an option to set the new (by Polylang created) directory “/en/” to ‘no-index’ as a whole?

    The /en/-directory shows up in my Sitemap:

    It’s automatically created by Yoast SEO, so how to make sure Yoast SEO doesn’t include it in their sitemap.


    If you set the translated page to noindex, it also shouldn’t show up in your sitemap anymore. I’m not particulary familiar with Yoast SEO these days as I found it too intrusive and switched to other plugins but I’d say that’s still your best option.

    Edit, found it here:

    • This reply was modified 4 years, 4 months ago by MNX.
    Thread Starter niekrosens


    Thanks Mnx!

    Just one more ‘amateur’ question. Because my page is an ‘onepager’ there is no specific page in WordPress for my English version (/en/) which I can put on ‘no index’. Any idea how to angle this?


    If I understand Polylang correctly, you have to link two pages together to make the language switching possible in the first place so if there is no english page, there should be no english content..? It must be in there somewhere. It’s hard to tell from the outside but depending on your setup it may be worth adding a dedicated /en page so you can noindex it properly.

    I also have this problem with two different websites, there is a conflict between Yoast and Polylang. None of the two methods described here are useful:

    The first method does not work: When choosing noindex on the other page, the page you want to index also acquires noindex.

    The second method Developer code: When applying the filter, you remove the page unwanted from the sitemap; but home is duplicated, at least in my case.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘How to prevent that Google shows my /en/-domain?’ is closed to new replies.