WordPress.org

Support

Support » How-To and Troubleshooting » How to prevent page title from appearing in post?

How to prevent page title from appearing in post?

  • To me It seems a bit redundant to have the title of a page name showing at the top of a page body (text area). Is there a way to disable this for a particular page, and without effecting SEO ?

    For example, if you look at my site “designbuddyDOTcom” the portfolio page doesn’t show the word “portfolio” at the top of the page, but pages like my “services”, “contact”, or “about me” page all show those. I guess since the page is already highlighted in the menu itself I don’t see the point in showing it again.

    One solution I’ve been told is to add the following to my css:

    .title_holder {display:none;}

    I’m not familiar with how code works so if anyone could let me know where I would place this snippet in my css and if it’s safe to do SEO wise. Thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • esmi

    @esmi

    Forum Moderator

    Not without affecting your SEO, no. The main page title is a primary SEO factor.

    Well, I don’t want to get rid of the page title, I just don’t want it displaying IN my page. For example, home pages and portfolio pages don’t have titles at the top of them; yet my about me, contact, and other pages do. I’m not doubting your answer, I just wanted to clarify. Thanks for your response.

    Is there any way to do this? You can see what I’m talking about if you visit my website designbuddyDOTcom. See how the “About me” page has “about” at the top of the page box? Yet when you visit the portfolio page, it doesn’t say “portfolio” at the top.

    its in the page template page.. depending on how your theme is set up, there will be different page templates for each page you create. Default is obviously the default.

    There is also single.php which you can remove the get_title from and that will remove titles from ALL pages

    This is how i remove the page title:

    Install All-in-one-seo plugin.
    Delete the “page title” and paste in All-in-one-seo option (page title).

    You can use a custom field and a little extra extra code arround the title.

    In the below example the custom field name is “hideTitle”, if set to “Yes” it writes in the class “.hideme”.

    php

    <?php
    //hide heading?
    $hideTitle = get_post_meta($post->ID, "hideTitle", $single = true);
    if($hideTitle !== 'Yes') {
    	the_title("<h1>", "</h1>");
    	} else{
    	the_title("<h1 class=\"hideme\">", "</h1>");
    	}
    ?>

    css

    H1.hideme{
    	display: none;
    }

    Have read that Google can detect if elements are hidden, but in my experience it indexes it as normal.

    Just read your last para’s re your coding ability.

    Most likely edit your index.php or single.php and replace the line
    the_title("<h1>", "</h1>");
    with my code.

    The CSS can go anywhere in style.css but to be neat put it under the existing H1 code.

    Thanks all. I will take all of your comments into consideration. Thanks for your time. Hema Latha, I do have “All in One” plugin installed and will try that method first.

    Hema Latha, I can’t seem to find where to delete the page title from the page. In my “about” page, I go to the “html” tab and don’t see a title anywhere. Any tips?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘How to prevent page title from appearing in post?’ is closed to new replies.
Skip to toolbar