Support » Plugin: Tooltipy (tooltips for WP) » How to prevent all images from loading at start page?

  • Resolved wydmuch

    (@wydmuch)


    Am am very satisfied with tooltipy, but it slows down my website, as all 100 images are loaded. This makes the website speed and size much bigger. It did not kown this, but Pingdom speed test shows that tooltipy function slows down my website at around 3 seconds which is too much.
    The images itself are already optimised.

    The question is, if tootipy is always loading ALL images at website start or is there a possibility to avoid this and load only if tooltip is needed on each page?

    Thanks in advance for your answers.
    regards wydmuch

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Jamel.Z

    (@lebleut)

    Hi @wydmuch,

    Thanks for your question and could you provide a page from your site so I can test ?

    thanks

    Thread Starter wydmuch

    (@wydmuch)

    Hi Jamel, the page is Produktfotografie und Werbefotografie

    Meanwhile I found out that excluding tooltipy from the start page helped reducing the page size from 16MB to 10 MB. This is still very big, I know, but as a professional photographer I need to show high quality pictures without too much compression.

    I just wonder, if I need to exclude more pages from tooltipy which whould be against the idea of having tooltip right in the text.

    Tell me what you think.

    Thread Starter wydmuch

    (@wydmuch)

    Sorry, I forget to mention that you find the tooltipy entries here https://www.glamourpixel.de/fotografie-lexikon/

    Hi @wydmuch
    What did you do to fix this problem?
    my website has this problem too
    thanks

    Thread Starter wydmuch

    (@wydmuch)

    Well, I deaktivated tooltipy for my start page, but unfortunately all pictures are loaded also for such small page like to contact page.

    https://www.glamourpixel.de/kontakt/
    Pindom Tools and Google Page Speed also tells that 100 images from tooltipy are always loded unnecessarily.

    Nowadays, there is also an error message in WordPress on ALL pages:

    Warning: preg_match(): Unknown modifier ‘R’ in /homepages/42/d630560502/htdocs/glamourpixel/wp-content/plugins/bluet-keywords-tooltip-generator/functions.php on line 128

    Don’t know what to do, maybe I need to deactivate tooltipy totally as it lowers my website speed.

    Plugin Author Jamel.Z

    (@lebleut)

    Hi again,

    ok let me look for a way to load images only an event is triggered

    but between take a look to the image of the “Livebild-Vorschau” tooltip, it’s a huge image, try to resize it and use jpg instead of png

    Thanks

    Plugin Author Jamel.Z

    (@lebleut)

    Hi again,

    I think I solved the problem for the free users 🙂

    If you are using the free version please download the v3.3.8 and try it out:
    https://downloads.wordpress.org/plugin/bluet-keywords-tooltip-generator.3.3.8.zip

    If you are using the pro version please try the v3.3.8 free after deactivating the pro one and let me know about the results 😉

    Thanks,
    Jamel

    Plugin Author Jamel.Z

    (@lebleut)

    Don’t forget to check the “Optimize images” new option in the Tooltipy settings to test

    Thanks

    Thread Starter wydmuch

    (@wydmuch)

    Hi Jamel,
    Thanks for your answer. If have installed 3.3.8 and cleared all caches. But still the kontakt page is loading all tooltipy images, which results in a 8 MB pageload.

    https://www.glamourpixel.de/kontakt/

    So far 3.3.8. does not have any effect for my page and the error message on every page is also still there:

    Warning: preg_match(): Unknown modifier ‘R’ in /homepages/42/d630560502/htdocs/glamourpixel/wp-content/plugins/bluet-keywords-tooltip-generator/functions.php on line 128

    As a photographer I do not use any image optimisation tools as they all reduce file size which results in less quality.

    Well, the pro version does not bring enough benefits to me at the moment.

    Maybe you can find a solution.

    Regards Marco

    Plugin Author Jamel.Z

    (@lebleut)

    Hi @wydmuch,

    nothing has changed because you didn’t checked the new option from Tooltipy/Settings/option –> “Optimize images”

    We can schedule a skype call to help if you need by the way

    Try it out and let me know

    Hey @aliardalan please do like I described above for Wydmuch to make your site load faster and let me know as well

    Thanks,
    Jamel

    Thread Starter wydmuch

    (@wydmuch)

    Oh, I see. It turns out to be my own mistake, right?
    Excuse me! Seems to be working now.

    But what can you say about the error message in functions.php line 128?

    regards Marco

    Plugin Author Jamel.Z

    (@lebleut)

    Great,

    About the error it’s because one of the keywords you inserted recently

    something like azerty/R …

    Thanks

    Thread Starter wydmuch

    (@wydmuch)

    Hi again Jamel,
    This “azerty/R” does not sound German or English and also no photographic language.

    I have 111 published keywords and 4 pending ones.

    Could you point me to the keyword in my photography dictionary which is causing the error?
    https://www.glamourpixel.de/fotografie-lexikon/

    Thanks in advance
    Marco

    Plugin Author Jamel.Z

    (@lebleut)

    I think this is it : “Ringlicht/Ringblitz”

    “/” is a special character causing this issue I believe so try to remove it and see if it solves the problem or use another character instead.

    Thread Starter wydmuch

    (@wydmuch)

    You are right, thanks Jamel.
    Great and quick support from you!

    I’ll write a positive review for tooltipy.
    Have a nice weekend!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘How to prevent all images from loading at start page?’ is closed to new replies.