WordPress.org

Support

Support » How-To and Troubleshooting » How to Post Via Email

How to Post Via Email

  • Hi Everyone,

    Can someone please explain how to set up the post via email option?

    I don’t understand what address I’m supposed to SEND to?

    Thanks.

    Darla

Viewing 14 replies - 1 through 14 (of 14 total)
  • The top secret one you set up in:
    admin -> options -> writing

    OK
    I did that.
    I set up secret passowrd for http://whatsdrivingyoucrazy.com/blog – with xxxx@whatsdrivingyoucrazy.com and secret password.
    I sent a post. It has not shown up and it has been more than ten hours.
    I checked the mail (without opening the post) and it was there in the inbox.
    Is there something I missed or failed to do? I found nothing besides setting up the e-mail address registration to activitate the service.
    Any help would be appreciated.
    OOPS! forgot to mention that is not the main domain for the Dreamhost account, but that should not make any difference, should it? The blog is all based on the applicable domain, right?

    You need to go to http://example.com/wordpress/wp-mail.php to get it to read your email.

    There’s a plugin called WP_Cron you can use to hit that page for you periodically so you don’t have to do it manually.

    Or if your host supports real crons, that’s a better solution. Just have it visit / execute wp-mail.php.

    Thanks everyone.

    Got it working fine now!

    hey guys, so i got everything setup correctly but my posts are only showing the subject as the title with no body. any help would be awesome! thanks

    I am having the same problem as above. I am only getting the email subject being posted.

    I’m having this problem as well. My subject line shows up as the post but nothing shows up from the body of the email.

    Have you had a chance to look through Blog_by_Email?

    You’ll want to make sure your email client is formatting the mails as text, not html.

    I’ve tried it with gmail and my blackberry, both of which use text, not html.

    btw, my first response here should have read: my email subject shows up as the TITLE of the post…

    I replaced the wp-includes/class-pop3.php with the one from 2.1.3 and that fixed the problem for me.
    You could also comment out line 372 “continue;” in class-pop3.php and that also solves the problem, but you might end up with a period at the end of the post. Also, make sure you’re using plain text, not HTML, when you write the email.

    joandcindy, YOU ROCK. Thanks so much I was also having the same problem, and read many others posts saying they had the same problem and somehow the answer was NO WHERE. It really surprised me. I randomly checked again a couple days later, and voila ! I commented out that line and I do get that extra . at the end, but that’s no problem at all and i’m happy it’s working !!!

    (I registered on this forum only to say thanks to you!)

    Very nice! I commented out line 372 and it worked for me as well!

    (I can live with the extra period and just edit it out later)

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘How to Post Via Email’ is closed to new replies.
Skip to toolbar