Support » Plugin: Duplicator - WordPress Migration Plugin » How to overcome hosting provider (Strato) PHP limits

  • Resolved g4qf4dv3lQ


    Dear lifeinthegrid,

    Duplicator fails in my case because of hosting provider PHP limits which I can not change:

    1. PHP script will be cancelled automatically if a file created by the PHP script is getting larger than 30 MByte
    2. max_execution_time = 120 sec

    These limits are fixed and can not be changed by the user (STRATO PowerWeb Starter).

    Therefore Duplicator can not finish the task, if the file size of the backup (wp-snapshots) is getting larger than 30 MByte.

    Is it possible to segment the Duplicator task in files with smaller file size ? e.g. writing multiples zip or rar files with e.g. only 20 MBytes file size.

    This could be a new Duplicator option (to define file size, e.g. full size, or a certain segment file size) to overcome annoying PHP limits of the hosting providers.

    Thanks and best regards,

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Cory Lamle


    Hey G4qf4dv3lQ,

    In future version I’ll be looking into logic for segregated queue requests. Right now the lib ZipArchive is limited on its close response and picking it backup to rebuild requires quite a bit of new logic. I hope to handle timeout issues better in future versions…

    In the meantime you may have to manually exclude any large directories and then manually move them over, sorry for the inconvenience! Hopefully by the time the plugin gets out of beta it will have this issue resolved for hosts that will not allow longer processes to run.

    The next version 0.5.0 which you can download now under the Developers link has some scan screens to help pin-point the areas on your system that may be contributing to your timeouts…


    Since i’m with strato, i have the same problem. Any solutions yet for this problem ?

    Plugin Author Cory Lamle


    You can try the “Archive Flush” and mysqldump options from the Settings > General Tab.

    That has partly an effect.
    the size of the package is now 59 mb (the whole site is 87mb as shown in the scan, which gives all good in green )
    Still getting a build interrupt

    serverstaatus 200-ok
    error-msg: (empty, no message here)

    Some servers close connections quickly; yet the build …etc

    It seems to create the database but jumps out during the zip part.
    These are its last lines:

    Items archived [1012] flushing response.
    Items archived [2019] flushing response.
    Items archived [3018] flushing response.

    Any thoughts ?

    Plugin Author Cory Lamle


    Hey @thebarfly,

    This is the only other suggestions I really have for these issues at the moment:
    -> Browse to:
    -> Find section: “3. Troubleshoot=> ”

    Hope that helps!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘How to overcome hosting provider (Strato) PHP limits’ is closed to new replies.