Support » Plugin: Hustle - Pop-Ups, Slide-ins and Email Opt-ins » How to not display it with 404 built upon Elementor?

  • Hi

    I use Elementor single template to display my 404 page.

    The body classes are:
    <body class="error404 logged-in wp-custom-logo wp-schema-pro-1.1.7 ast- astra-1.4.10 ast-header-custom-item-outside group-blog ast-mobile-inherit-site-logo ast-flyout-menu-enable ast-default-above-menu-enable ast-flyout-right-side ast-default-below-menu-enable ast-full-width-header ast-inherit-site-logo-sticky ast-inherit-site-logo-transparent ast-theme-transparent-header elementor-page-6185 elementor-default astra-addon-1.5.2">

    My diplay settings are:
    https://s26.postimg.cc/5uy1pd5uh/hustle2.jpg
    https://s26.postimg.cc/guj90yojt/hustle1.jpg
    https://s26.postimg.cc/lgfd9bpih/hustle3.jpg

    Unfortunately the popup is still displayed when a 404 error is fired… 🙁

    Thanks

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @pako69,

    I just gave this a swirl and by default my Elementor made 404 didn’t show popup, I didn’t need to adjust anything.

    Did you use the same way of creating 404 page as explained here https://elementor.com/customized-404-page/ or you went some other way?

    Does it show for you on all 404 pages or just some of them?
    For example, if you go to domain.com/doesntexist it doesn’t show, but if you go to some non-existing post like domain.com/category/doesntexist it shows?

    Cheers,
    Predrag

    “Did you use the same way of creating 404 page as explained here https://elementor.com/customized-404-page
    > Yes, the same, it’s just a single with condition to display only on 404 Page…

    > It show up on every 404 pages, no matter if it’s a page, a post, with or without sub-folder ine the url

    Plugin Support Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @pako69,

    After some additional testing I was able to replicate the issue and it seems that conditions are causing it 🙁
    Without any conditions it doesn’t show it on 404 page but the conditions do fire it up.

    I have created a bug report for our developers to investigate it further.
    Thank you for bringing this up to our attention!

    Cheers,
    Predrag

    Great 🙂
    Thanks

    FYI it has the same issue with Archive page: authors pages, search result pages. Etc.
    Both Elementor template are using conditional display…
    Thanks

    • This reply was modified 6 months, 1 week ago by  pako69.
    Plugin Support Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @pako69,

    Can you tell me how was this template created, I used Archive and Post Type and for conditions I set Archive and Search but I don’t see the popup on those pages.
    I have a feeling I’m missing something here? 🙂

    Cheers,
    Predrag

    pako69

    (@pako69)

    I’m not sure about what you are asking me… but:

    For displaying authors archive, it’s an Elementor archive template – conditional logic = instance: “Author Archive”

    For displaying search result, it’s an Elementor archive template – conditional logic = instance: “Search Results”

    And my popup display seeting are still the same :
    https://s26.postimg.cc/5uy1pd5uh/hustle2.jpg
    https://s26.postimg.cc/guj90yojt/hustle1.jpg
    https://s26.postimg.cc/lgfd9bpih/hustle3.jpg

    That’s all…

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello there @pako69,

    hope you’re doing good and please excuse our late response here!

    I was able to replicate the same in a testing site of mine.
    Despite the conditions here:
    https://monosnap.com/file/lpAc81CIb8laVYwTytApqP34lIQgHz
    popup is coming up for both Author Archives and Search Results.

    I’ve already updated the report made already to our developers.

    Warm regards,
    Dimitris

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello there @pako69,

    hope you’re doing good today! 🙂

    I had some feedback from our developers on this. It seems that we’re experiencing the correct behavior because the template is only a Custom Post Type in title. And they add a shortcode like [elementor-template id="102"] to a page and it’s only part of page. And Hustle checks the post type – and it’s page, pages are accepted and it shows popup. But if you open real CPT (https://i.imgur.com/ZvuR2w0.png) it won’t show.

    Unfortunately there’s no workaround for this, our developers pushed a fix though, for the main issue about showing popup on 404 page, if other Display Rules are set. This will be part of a future update, can’t really share any estimated time on this though.

    Warm regards,
    Dimitris

    pako69

    (@pako69)

    Hi

    Not clean, but it does the trick:
    .error404 .wph-modal, .search .wph-modal, .archive .wph-modal {display:none !important;}

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.