Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » How to migrate from production to staging environment?

  • Resolved megafanat

    (@megafanat)


    I have installed the Google Site Kit plugin on my production website, configured it, and connected it to Google Analytics.
    Now I want to make a local copy of the site because I want to experiment with it.
    Google has instructions on how to properly transfer a site from a staging environment to a production one. But I did not find instructions on how to do a reverse transfer – from a production site to a test one.

    Please tell me what is the correct sequence of steps to transfer a site with the installed Google Site Kit?

    I am using the Duplicator plugin. I suspect that after transferring and entering the test site, Google Site Kit will start sending some data from the test site to Google, which may lead to problems. Maybe I should deactivate it before cloning? Or I should do something else?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Abdullah Ramzan

    (@abdullahramzan)

    Hey,

    Thanks for opening a support topic.

    Let us do the same activity at our end. It can take time so we’ll update you once we have some useful information to share.

    Best Regards,

    Plugin Support Abdullah Ramzan

    (@abdullahramzan)

    Hey,

    Providing you’re performing a backup and restore to a staging site (which is online and not a local site) you can follow the steps below:

    1. Reset Site Kit to ensure your current product site with URL and access tokens is not registered on the Site Kit service. (Note that when resetting Site Kit all connected services will be reset for each connected user. )
    2. Perform a backup and restore using Duplicator
    3. Reconnect Site Kit on your live site
    4. On your restored staging site follow the steps on the plugins website documentation for “Using Site Kit on a staging site

    Following the above steps you should be able to view your live site data on your cloned site.

    Let us know if you still have any questions.

    Thread Starter megafanat

    (@megafanat)

    Thanks for the answer. I performed steps 1-3. The production site works well.
    Then I deployed the local site from the backup file. I successfully completed step 4 from “Use Site Kit with a staging environment”.

    And in step 5 I ran into a problem.

    If you don’t have a GCP app yet, you can click the Create your credentials link on the Developer settings page.

    I click “Create your credentials” link. “Site Kit | Google Developers” page is opened. It contains a list of my site parameters. I am not sure that all are correct but I cannot change them. They all are read-only. I click button “Get OAuth Credentials”. Dialog “Site Kit: Get OAuth Credentials” appears. I click NEXT in this dialog. And it shows me a message “The request failed because one of the field of the resource is invalid”.
    It does not show what parameter is invalid. And I do not know how to change parameters. They are unmodifiable.

    How do I know which parameter is wrong? How can I change it?

    Plugin Support Abdullah Ramzan

    (@abdullahramzan)

    We need to apply the same activity for local site as well and after that we’ll let you know. In the meantime can you pleas deploy the same backup on the staging remote server & then try to create API keys.

    Happy Weekend!

    Best Regards,

    Plugin Support Abdullah Ramzan

    (@abdullahramzan)

    Hey,

    Site Kit is not fully functional on the local website as you couldn’t create credentials to use Site Kit through Tester plugin. So you need to migrate site to the staging environment(remote server) & can play around.

    Thanks for your patience. Have a great day.

    Best Regards,

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.