Support » Fixing WordPress » How to manually replace commercial theme (that is failing to load) with default

  • Resolved madmartian

    (@madmartian)


    I have a problem with a cyberchimps theme that I don’t even remember installing – a fatal error. I don’t want to fix it – I just want to go back to the default wordpress theme. How do I do that manually while the site won’t load due to the cyberchimps problem? I tried renaming the gdminimal folder and while that eliminated the fatal error, it did not cause the page to load. I likely have a very old version of both wordpress and themes on this site – the highest base theme currently installed is twentyfifteen. The version of wordpress installed will be from that same era. Once I get the page to load again I can update it.

    Here is the fatal error, but remember I want to remove cyberchimps, not fix it – unless fixing it is easier than switching back to a default theme manually. Debug is on and you can see a bunch of warnings at the link as well. PHP is 7.1 and has to stay that way until I upgrade my shopping cart.

    Fatal error: Uncaught Error: [] operator not supported for strings in /home/wjf90ljtxjte/public_html/rtc/wp-content/themes/gdminimal/cyberchimps/options/options-sanitize.php:162 Stack trace: #0 /home/wjf90ljtxjte/public_html/rtc/wp-includes/plugin.php(213): cyberchimps_sanitize_section_order(Array, Array) #1 /home/wjf90ljtxjte/public_html/rtc/wp-content/themes/gdminimal/cyberchimps/options/options-init.php(1073): apply_filters(‘cyberchimps_san…’, Array, Array) #2 /home/wjf90ljtxjte/public_html/rtc/wp-content/themes/gdminimal/cyberchimps/init.php(84): cyberchimps_get_default_values() #3 /home/wjf90ljtxjte/public_html/rtc/wp-includes/plugin.php(496): cyberchimps_core_setup_theme(”) #4 /home/wjf90ljtxjte/public_html/rtc/wp-settings.php(337): do_action(‘after_setup_the…’) #5 /home/wjf90ljtxjte/public_html/rtc/wp-config.php(80): require_once(‘/home/wjf90ljtx…’) #6 /home/wjf90ljtxjte/public_html/rtc/wp-load.php(29): require_once(‘/home/wjf90ljtx…’) #7 /home/wjf90ljtxjte/public_html/rtc/wp-blog-header.php(12): require_o in /home/wjf90ljtxjte/public_html/rtc/wp-content/themes/gdminimal/cyberchimps/options/options-sanitize.php on line 162

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Access your website’s files via FTP or web-based File Manager, and delete or rename the theme’s folder, gdminimal. (Your hosting comes with cPanel, so you have a web-based FILE MANAGER in there).

    • This reply was modified 2 months, 2 weeks ago by George Appiah.
    • This reply was modified 2 months, 2 weeks ago by George Appiah. Reason: Added info for clarity

    I already tried that – mentioned it in the original post. While it made the fatal error go away, the page still wouldn’t load. I just renamed it again so you can see what it looks like without the fatal error.

    Did you perhaps skip over a few things you did? Your problem is with the version of PHP being used which is not working correctly with old Plugins. If you want to solve your problem go back to PHP v5.6 and do some WordPress Updates.

    Mostly likely everything will work again after the updates and more importantly, the site will work correctly. Then you can upgrade PHP and any problems you do have will be a lot easier to sort out.

    If you don’t want to downgrade PHP then delete the site and start over.

    I just renamed it again so you can see what it looks like without the fatal error.

    And are you still unable to login to the dashboard after this? Have you really tried?

    You’re dealing with multiple issues here.

    The theme’s issue was resolved after renaming or deleting. After this, the front end will show a blank screen (assuming there’s no other issue) since the active theme cannot be loaded. When you log in to the dashboard, WordPress should automatically switch the active theme to the default.

    Then there is the PHP deprecation issue. It appears you’re using an older version of WordPress/plugins which don’t play nice with PHP 7.1, hence website-rob’s recommendation to downgrade. Under normal conditions, a DEPRECATION notice shouldn’t stop the site from working, so you should be able to login to the dashboard in spit of the error you see on the screen.

    • This reply was modified 2 months, 2 weeks ago by George Appiah. Reason: Fixed typo

    madmartian.com/rtc/wp-login.php

    Produces a fatal error:

    Fatal error: Uncaught Error: Cannot create references to/from string offsets in /home/wjf90ljtxjte/public_html/rtc/wp-includes/user.php:54 Stack trace: #0 /home/wjf90ljtxjte/public_html/rtc/wp-login.php(775): wp_signon(”, ”) #1 {main} thrown in /home/wjf90ljtxjte/public_html/rtc/wp-includes/user.php on line 54

    In regards to PHP, I was able to get two other old wordpress sites working that I believe started at the same version. One worked without issue and just needed updating while the other had a fatal error with a cache plugin. Disabling the plugin allowed me to login and upgrade. This third site had the fatal error with cyberchimps, which was not on the other two sites. As far as I know, all three sites had the same old version on them to start with. All managed under the same hosting account with PHP 7.1.

    Oooh! I searched for that new error and found the solution! Login prompt fixed!

    Now if I can just remember that old password – apparently not the same as the other two sites. <sigh>

    I will post again when I get past that…

    Oh wow! I am having another weird issue. I might have to post separately for this one. For some reason my third wordpress site is redirecting to my second wordpress site! No idea why this is happening. These were created separately and have different content.

    Site 3: madmartian.com/rtc or rtcguy.com
    Site 2: madmartian.com/toys or toylunatic.com
    [these are subdomains]

    If I click on “lost password” at
    http://madmartian.com/rtc/wp-login.php
    I end up at
    https://toylunatic.com/wp-login.php?action=lostpassword

    Likewise if I go to
    http://madmartian.com/rtc/wp-admin/
    I end up at
    https://toylunatic.com/wp-login.php?redirect_to=http%3A%2F%2Fmadmartian.com%2Frtc%2Fwp-admin%2F&reauth=1

    How on earth do I get rid of that redirect? I looked at my domain settings and I don’t have any redirects setup through my host – says “not redirected” for both those subdomains. Must be in a wordpress file somewhere?

    Well I solved that problem. Had to edit fields in the database through phpmyadmin. Somehow the homepage got set to a different wordpress site. All is good now. Thanks.

    It’s good to hear you were able to sort out your problem.

    Please mark this thread as Resolved.

    Done.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.