WordPress.org

Forums

[resolved] How to Make References Relative (7 posts)

  1. chaplaindoug
    Member
    Posted 3 years ago #

    I noticed after installing (on my Windows Server 2008 server) and working on my WordPress site, that all references to files and pages (and permalinks) look like "http://10.251.0.1/wordpress/ . . ." 10.251.0.1 is the local area network IP for the server and will mean nothing to users once the site goes live. I have already tried viewing the site outside the LAN and any graphic, file, or page (other than the home page) does not come up.

    SO, how can I make all the referecnes and permalinks relative? Instead of http://10.251.0.1/wordpress/wp-content/... for instance why not just wp-content/...? I tried that on some images I have in HTML on a page and it works. If I cannot make it relative, then how can I replace to 10.251.0.1 with the actual web address (e.g., new.mydomain.org)? Any help will be greatly appreciated. Thanks.

  2. leonmagee
    Member
    Posted 3 years ago #

    Once you get your live site running it should work fine.

    You should only use hard-coded links if you have to. If you do, you can code them with the URL of the page on your live site.

    The permalink structure should resolve itself.

  3. chaplaindoug
    Member
    Posted 3 years ago #

    I have gone "live" in that I now have an external IP address assigned, which is mapped by my firewall to the internal IP. When I try to use it, it does not resolve. The site comes up. But without some of the graphics. It works internally, but not externally. There must be something else going on. Any ideas?

  4. leonmagee
    Member
    Posted 3 years ago #

    Are you going to eventually move this to an external host, or are you trying to host on your own server?

  5. chaplaindoug
    Member
    Posted 3 years ago #

    I plan to host it on my own server. I have no problem developing my ASP.Net web sites on our servers. I am just having trouble with this WordPress site. Any suggestions?

  6. chaplaindoug
    Member
    Posted 3 years ago #

    The solution to my problem was to log in as admin. Go to settings>general and to set the web site address there near the top. Thanks.

  7. chaplaindoug
    Member
    Posted 3 years ago #

    Solved.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.