WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] How to make links in a post dofollow?

[Resolved] How to make links in a post dofollow?

  • How can I make links inside my blog posts dofollow?

    Now I dont care about making the people who comment on my blogs links dofollow, they already are.

    Ive also manually gone in and add a rel=”dofollow” tag to make my links dofollow. The weird thing is only one of three links that I put the tag actually changed to dofollow.

    Can you help?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Moderator Kathryn

    @zoonini

    How can I make links inside my blog posts dofollow?

    You don’t need to do anything. Links in posts and pages (except for comments) are able to be spidered by default, unless your entire page has a “nofollow” meta tag on it.

    How can I check if my page has a nofollow meta tag all over it? And how do I remove it

    Moderator Kathryn

    @zoonini

    You can either provide a link to your site and I can take a look, or you can view the source and look in the head section for something like this:

    <meta name="robots" content="nofollow">

    Moderator Kathryn

    @zoonini

    And if you see that, go into your header.php to remove it or check your WordPress settings under Settings > Privacy and make sure your site is set to be spidered by search engines.

    http://codex.wordpress.org/Settings_Privacy_Screen

    Nope it doesnt have that tag. If you want u can take a look at my site:

    http://www.guidegoodshq.com

    Moderator Kathryn

    @zoonini

    So you’re good to go.

    How come when I check my links on my blog post still show up as nofollow?

    I have a Firefox addon that automatically distinguishes dofollow and nofollow links

    Moderator Kathryn

    @zoonini

    I’m not sure why it would show that – maybe the addon is defective. The only nofollow links I see are within your comments. I also ran your URL through a search-engine spider simulator and it’s spidering everything: http://www.webconfs.com/search-engine-spider-simulator.php

    Moderator Kathryn

    @zoonini

    Ah – within your posts I do see some nofollow tags on your links:

    http://guidegoodshq.com/2011/07/professional-webmaster.html

    Example:

    <a rel="nofollow" target="_blank" href="http://www.techterms.com/definition/webmaster" rel="dofollow" >

    Not sure where those two nofollow and dofollow tags are coming from. Have you tried turning off all your plug-ins?

    Moderator Kathryn

    @zoonini

    I reread your first post and saw that you added a plug-in to get the “dofollow” tag in there, but the question is where are those “nofollow” tags coming from. I would try deactivating all your plug-ins to see if they go away and then turning them back on one by one to see if one of them is the culprit.

    After looking inside my post editing area there was a something that said “Leave unmarked if you dont want the search engines to follow your links in the post”

    I checked it so the search engines can search the links.

    Can you check if there dofollow now?

    Moderator Kathryn

    @zoonini

    I’m still seeing this: <a rel="nofollow" href="http://www.techterms.com/definition/webmaster">webmaster</a>

    You should find out why that checkbox is there: “Leave unmarked if you dont want the search engines to follow your links in the post” and have it removed. My guess is that some plug-in is adding it. As I’ve said, there should be neither rel=”nofollow” nor rel=”dofollow” on links within posts and pages by default.

    I think problem is on your SEO plugin, SEO plugin like yoast have an option to make dofollow or no follow. check out the below link.

    http://twitpic.com/5ycysl

    It turns out my template has a nofollow feature turned on and another plugin hasd a nofollow thing too. Thanks guys 🙂

    Moderator Kathryn

    @zoonini

    Glad you figured it out!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] How to make links in a post dofollow?’ is closed to new replies.