• Resolved Sixtus78

    (@sixtus78)


    I have problems with a new page I’m developing.
    The member directory does not show any users if not logged in. After logging in everything works just fine.
    I have an older page with a public member directory – but I cannot find any specific setting there.
    So my question is, how do I make a member directory public?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @sixtus78

    To display the users for logged-in and non-logged-in users, you need to deselect the roles in the “User Roles that can use search” options.

    Go to WP Admin > Ultimate Member > Membe Directories > Edit a directory > see “Search Options” > see “User Roles that can use search”.

    Regards,s

    Thread Starter Sixtus78

    (@sixtus78)

    All roles are deselected there. Still users are only shown when logged in.

    • This reply was modified 6 months, 1 week ago by Sixtus78.
    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @sixtus78

    Could you please provide a screenshot of the user role settings that have this issue? Also, another screenshot of the Member Directory settings.

    Regards,

    • This reply was modified 6 months, 1 week ago by Champ Camba.
    Thread Starter Sixtus78

    (@sixtus78)

    This is very kind of you. I am using UM Version 2.1.16 with WP 5.7.

    These are the settings for the member directory:
    Settings Member Directory

    Here is the user role (“Händler”) that is listed in the directory:
    Screenshot Custom Role “Händler”

    I just cross-checked the settings with my older, working example and cannot find any differences yet.

    Thread Starter Sixtus78

    (@sixtus78)

    Just found out that when adding new members of the same role, these are shown. Existing members are not.
    Is it possible that older members are not shown when adding new fields to the registration form?

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @sixtus78

    Could you please check the older member’s privacy settings when you log in to their account? Maybe their account is set to Private or hidden from the Member Directory.

    Thread Starter Sixtus78

    (@sixtus78)

    Unfortunately, this isn’t it. The setting “Allow users to hide their profiles from directory” is turned off.

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @sixtus78

    Could you please contact us via team@ultimatemember.com so we can do a further investigation?

    Please include the link to this topic in the email message.

    Regards,

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @sixtus78

    This thread has been inactive for a while so we’re going to go ahead and mark it Resolved…

    ..Please feel free to re-open this thread by changing the Topic Status to ‘Not Resolved’ if any other questions come up and we’d be happy to help. 🙂

    Regards,

    Thread Starter Sixtus78

    (@sixtus78)

    Thank you for you help and time Champ.

    Deleting the plugin and all users was the only thing that finally helped.

    Thanks again for being so reactive here!

    Kind regards,
    Daniel

    • This reply was modified 6 months ago by Sixtus78.
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘How to make a member directory public?’ is closed to new replies.