Support » Plugin: Advanced Custom Fields: Font Awesome Field » how to load only some of the fonts?

  • I’d like to improve performance by only loading some of the Font Awesome fonts. I don’t need Brands, Bold, or Duotone. How can I do this?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Matt Keys

    (@mattkeys)

    When you are creating your FontAwesome field in ACF, you can select which of the font sets you want to load using checkboxes.

    It doesn’t seem to work. I have limited fonts (i.e. no brands) selected in my field definition, but in the admin I do see the brands when I am selecting an icon.

    (I wish I could upload screenshots)

    Plugin Author Matt Keys

    (@mattkeys)

    Hmm, not sure what would cause your installation to act differently. Can you verify you are on the latest versions of ACF + my plugin. And then perhaps update/re-save the field settings for that FontAwesome field (and if you have more than one make sure you are editing the correct one).

    Matt,
    I’m using the latest versions: 3.1.1 ACF FontAwesome, 5.8.7 ACF Pro.

    If I check “turn on the pro icons”, I have all icons available in the ACF fontawesome field, no matter what icons I have selected in the field definition. I do want the pro icons. I just don’t want every font weight, and I don’t want the brands icons.

    Updating and re-saving the field doesn’t make any difference.

    • This reply was modified 4 months, 2 weeks ago by photocurio.
    Plugin Author Matt Keys

    (@mattkeys)

    Thanks for the reply. I just did some more testing with the pro icons as you indicated to see if there was a bug somehow related to having those enabled. Unfortunately I still can’t recreate the issue that you are reporting. In my latest test I only left ‘light’ icons checked, and only light icons were available when using that field on pages (where that field group was assigned).

    Because I haven’t been able to reproduce this issue, and because it hasn’t been reported by anyone else, it seems like this there may be a specific set of circumstances unique to your environment that must happen to see this problem (unless this is somehow user error or we are misunderstanding eachother?).

    If your environment allows, you could try disabling unrelated plugins to see if there are any conflicts, try switching out your active theme once again to see if there are any conflicts. Or another tact would be to try to recreate this problem in a fresh barebones environment. If you are able to recreate the issue that way you could provide steps to reproduce the issue that hopefully I can follow and patch whatever bug may be present.

    Sorry there are no easy answers here, it is always difficult to fix these issues I cannot see or reproduce in my own testing. If anyone else if experiencing this issue as well, please write in with whatever details you can share that may help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.