Support » Plugin: Quotes llama » How to link the source field to an actual source URL

  • Resolved pixeldrummer

    (@pixeldrummer)


    I am struggling a bit with wanting to linking the Source field to the actual source URL. Better yet, create that link for the source icon. I created the link <a href=”… ” target=”_blank”></a> surrounding the Source information, but while the link shows but it is null. What am I missing? Can you help?

    All settings are still at default. Installed the plugin yesterday. Only using Quote and Source fields. Thank you.

    • This topic was modified 11 months, 4 weeks ago by pixeldrummer.
    • This topic was modified 11 months, 4 weeks ago by pixeldrummer. Reason: edited for precision
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author oooorgle

    (@oooorgle)

    Hi pixeldrummer,

    At the moment there is no way to make the icon itself part of a link.

    You could link an image directly into the source: (It’s what the plugin does with a custom icon, but just not in an “a” element.)

    <a href="https://wordpress.org/support/plugin/quotes-llama/"><img src="yourimage.jpg">Quotes Llama</a>

    Then it seems an issue of having icons enabled or not. Interesting idea however… I will give it some thought about incorporating icons like that… perhaps the first link it detects it would use. Like the quote field, any variations of text and links all mixed can exist so there could be multiple links.

    Anyways, back to the problem, when I add a source containing: <a href="https://wordpress.org/support/plugin/quotes-llama/">Quotes Llama</a> it displays the expected linked text “Quotes Llama”. Do you get the same result when copying the above into a quote source?

    • This reply was modified 11 months, 4 weeks ago by oooorgle.
    Plugin Author oooorgle

    (@oooorgle)

    Can you provide what you are using to call the plugin, the short-code or widget settings?

    Thread Starter pixeldrummer

    (@pixeldrummer)

    Thanks for your reply. Here is a link to the draft site: https://courtenaybahai.waggis.ca/ The quotes are below the image.

    I turned off any icons. Am only using the quote field and source field. Am using Theme.co Pro Theme, which has its own quirks. Am using a text field in a section with the shortcode: [quotes-llama]. I have linked all 4 quotes now, but can’t refresh and see them rotating through, I have to clear the temp internet files every time. So testing is a problem. The 2 ‘Hidden Words’ quotes are directly linked, the other 2 have the target=”_blank”. I appreciate your help, thank you.

    As an aside I wanted to mention that I had used your earlier plugin (several years ago) on an html page and it worked beautifully until recently, so I recognized the name. (https://bahaidates.org).

    Plugin Author oooorgle

    (@oooorgle)

    When viewing that page I see one quote under the image that displays the quote and source. Viewing the page source it also only has one quote.

    Are you using a caching plugin? For instance: https://wordpress.org/support/topic/same-quote-loads-with-random-shortcode/

    Thread Starter pixeldrummer

    (@pixeldrummer)

    Yep, I thought that might be a problem. LightSpeed Cache. I turned it off now. This is going to be a very small site. Doesn’t need a cache. It’s like shooting a flea with a cannon.

    Now the quotes rotate, but the source links don’t seem to work. It’s not cruicial, but it would be nice.

    • This reply was modified 11 months, 4 weeks ago by pixeldrummer.
    Plugin Author oooorgle

    (@oooorgle)

    When I click the sources they do link through. Seems to be functioning now.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘How to link the source field to an actual source URL’ is closed to new replies.