Support » Plugin: W3 Total Cache » How to let W3-total-cache update via FTP?

  • Resolved 4thfront

    (@4thfront)


    When I tried to update to the latest version of your plugin, it said … “W3 Total Cache Error: Files and directories could not be automatically created to complete the installation.”

    I think this may be because my i-Themes Security plugin is set to prevent any file writing permissions.

    The error message area also says … “FTP credentials don’t allow to write to file /home/___/public_html/.htaccess”

    But when I click on your manual bypass [a button that says “Update via FTP”], nothing happens.

    Is there something I need to tell my host/server to do … to allow your plugin to do the update via FTP?

    My host/server is the “Stellar” shared plan from NameCheap.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @4thfront

    I am sorry about the issue you are experiencing and I am happy to assist you with this.
    Sometimes due to the security plugins, other plugins lost their writing permission to .htaccess and other files.
    You need to check your files/folders permissions. For W3 Total Cache to write to files and folders, you need to change folder permission to 755 and your .htaccess to 644
    Simply FTP to your website or use Cpanel and change the permissions.
    I hope this helps!

    My wp-config.php and .htaccessare are at 444 and the rest are 755.
    Do you need wp-config.php higher than 444?
    Is there a way to keep .htaccessare at 444 in general … but setup an exception access for you?
    Thanks.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    In wp-config W3 Total Cache needs to add define(‘WP_CACHE’, true); so it should look like this:

    /** Enable W3 Total Cache */
    define('WP_CACHE', true); // Added by W3 Total Cache

    But this you can add by yourself and don’t change the permission.
    As for .htaccess, W3 Total Cache writes the rules depending on your settings. You should change the permissions for your .htaccess to 644 and after you are satisfied with the configuration you can revert it to 444.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.