Support » Plugin: Slider - Ultimate Responsive Image Slider » How to keep captions appearing on mobile?

  • With the UR Image Slider plugin, the captions disappear for tablet or mobile widths. We would like to retain the captions. Please advise how we can customize CSS to be able to do this.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Weblizar

    (@weblizar_support)

    Hello jrh001,
    please share the gallery URL where you are suing thye plugin.
    Thanks.

    Thread Starter JeremyRHammond

    (@jrh001)

    Weblizar

    (@weblizar_support)

    Hello jrh001,
    for this, follow the below steps-
    1) Open the file “uris-layout.php” from the plugin folder.
    2) On line no. 195 & 205, set the value to “block”.
    3) Save the file.
    For reference you can see here
    Thanks.

    • This reply was modified 4 years, 7 months ago by Weblizar.
    Thread Starter JeremyRHammond

    (@jrh001)

    That suggestion did not produce the desired result. Not wanting to modify the plugin files, I tried adding the following to my child theme’s style.css:

    @media (max-width: 640px) {
    .hide-small-screen {
    display: block !important;
    }
    }
    @media (max-width: 860px) {
    .hide-medium-screen {
    display: block !important;
    }
    }

    That didn’t work, so I tried just modifying the uris-layout.php file directly as per your screenshot and instructions. However, setting the value to “block”, clearing the WP Rocket cache, clearing my browser cache, and refreshing the page, the result is the same. The captions disappear at 860 px as I size down my browser. I also tried adding “!important” after “block” directly in the plugin file, but this also had no effect.

    Please further advise how I can get the desired result, i.e., retain captions for tablet and mobile devices.

    Weblizar

    (@weblizar_support)

    Hello jrh001,
    please contact us through our site
    We’ll definitely help you out.
    Thanks.

    Please post the solution to this problem on this forum, as I am also having this problem on mobile. Thank you!

    Weblizar

    (@weblizar_support)

    Hello lydia_b,
    For changing in plugin files, it will work on all the galleries-
    1) Open the file “uris-layout.php” from the plugin folder.
    2) On line no. 195 & 205, set the value to “block”.
    3) Save the file.
    For reference you can see here

    And if you want to apply for a specific gallery, you can paste the following section of code in custom css-

    @media (max-width: 640px) {
    .hide-small-screen {
    display: block !important;
    }
    }
    @media (max-width: 860px) {
    .hide-medium-screen {
    display: block !important;
    }
    }

    Thanks.

    Thread Starter JeremyRHammond

    (@jrh001)

    I have sent an email to you via your website and look forward to following up via email. Thanks.

    OK, we got it and replied you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘How to keep captions appearing on mobile?’ is closed to new replies.