WordPress.org

Support

Support » How-To and Troubleshooting » How to insert pictures into new posts / pages?

How to insert pictures into new posts / pages?

  • I am not able to view the fonts toolbar.
    Thus I am not able to bold the words.

    I am not able to insert picture too.

    I had installed WordPress 2.7
    Running on both Firefox3.07 & IE7 Browser.

    Please advise.
    Hear from you soon.

Viewing 15 replies - 1 through 15 (of 16 total)
  • I was able to insert a picture on my first post using the upload/insert image box above the posting area.

    Now, when trying to do the identical process, I get this message:
    Unable to create directory /data/17/1/37/105/1689920/user/1823177/htdocs/DougShields/bsportsblog/wp-content/uploads/2009/03. Is its parent directory writable by the server?

    I have tried it with the previously successful image and others. Any ideas how to fix this or make it work?

    denniskwan,
    Maybe switch from “html” view to “Visual” with the upper right tab over the posting box. Not sure, but I think I originally had the same problem and accidently “fixed” it by changing the view.

    Sorry, I was not clear. The idea above for denniskwan was for the fonts and bold toolbar. The picture/image/media tools have been there for me the whole time.

    I still need help with my posting images problem posted above.

    I was able to insert a picture on my first post using the upload/insert image box above the posting area.

    Now, when trying to do the identical process, I get this message:
    “Unable to create directory /data/17/1/37/105/1689920/user/1823177/htdocs/DougShields/bsportsblog/wp-content/uploads/2009/03. Is its parent directory writable by the server?”

    I have tried it with the previously successful image and others. Any ideas how to fix this or make it work to insert pictures in a post?

    Did you install any plugin since your previous post when inserting pics was still working?

    I just discovered that the plugin from commentluv.com makes it impossible to insert pictures into a post. Disable it, make up your post and then enable it again. Or just remove it.

    I don’t know it this solves your problem but it’s worth a try.

    I am not aware of installing a plug in. Certainly could have by accident since I do not know how to do one yet. Sure will take a look. Thank you!

    My son had activated the “Poll” plug in. I tried deactivating and downloading an image again. Same message:

    Add media files from your computer
    Unable to create directory /data/17/1/37/105/1689920/user/1823177/htdocs/DougShields/bsportsblog/wp-content/uploads/2009/03. Is its parent directory writable by the server?

    “Is its parent directory writable by the server?”

    I have now loaded “Press This” which allows you to get an image from a web site. Was able to get the image I wanted and everything seemed great, and then I went to publish and above message again.

    Somebody must know what to do?

    “Is its parent directory writable by the server?” This seems to be the question. There is not a place to answer, so it must be something we should know?

    Hello,
    There must be somebody that can help. I am new to this.

    This worked for me. Pretty simple and yet very few seem to know. It is not in the “sticky” at the front of this thread and went many posts deep in the one I finally found it in.

    Dancurranjr had it but I mis-read the post and didn’t get the benefit of this simple fix until later via another forum (hours later!) I did Bluehost live chat twice and though they were willing to help me they were unable. They had me doing all the complicated things that have been suggested here but in the end it was so simple!
    1. Login to your admin page
    2. Go to settings
    3. Go to Miscellaneous
    4. Find Store uploads in this folder
    5. if it says “/wp-content/uploads” just remove the first forward slash so that it reads plain ol: wp-content/uploads

    I had to remove a long string down to the “wp-content/uploads” and it worked.

    Or it could just be that the upload folder does not have the correct permissions? As the message suggests.

    Ie. Does the ‘upload’ folder have writable permissions, also referred to as CHMOD more commonly.

    Hi

    i also having this message when i load image into my blog.

    i have tried to chmod to 755 and change it to “wp-content/uploads” but still not working.

    regards

    @dshields: Thank you for your notes! My ISP changed the path to my home directory, so no amount of permission changes would have helped. Cheers,

    I recently updated WP so this is the latest version. I uploaded an image and I see this in the html view:

    <div style=”margin: 2em;”><span style=”display: none;”><img title=”NDX DD” src=”http://thebacktester.com/wp-content/uploads/2009/01/NDX-DD1-1024×723.jpg” alt=”” width=”1024″ height=”723″ /></span></div>

    When I preview the post, however, no image is visible. Can anyone help?

    Thanks and Happy New Year!

    Maybe a time-out? Is the image under 100 kB?
    What happens when you take out the <span style="display: none;"> and the closing span ?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘How to insert pictures into new posts / pages?’ is closed to new replies.
Skip to toolbar