WordPress.org

Forums

Redirection
How to ignore specific 404 errors ? (1 post)

  1. jrf
    Member
    Posted 4 years ago #

    L.S,

    I'm using the latest version of the redirection plugin (2.2.5) and I'm trying to use the power of the 404 module as described on the redirection website:

    the power of this module comes from the fact that redirections created inside it will be ignored from the 404 log. In other words, the module records all 404 errors except the specified URLs.

    Based on this information, I:

    • created a group within the 404 module with the default settings (tracked & enabled both on)
    • added a few rules to this group mainly to ignore certain 'bad bots'. They should get a 404 error automatically anyway, so I set them up with the recommended 'do nothing' action (which feels a bit counter-intuitive in this case where 404 would seem more appropriate).

    Now, in spite of what I would expect, the 404 errors are still being logged.

    I can edit the group and disable tracking (which does stop logging the errors), but then why did I need to create a group within the 404 module and use the 'do nothing' action ?

    So in short I'm very unclear on how this should work.

    I *would* like to see how often the rules I set up are being hit, but I don't want to see the 404's for these rules in the log.

    Any help or suggestions on how this *should* work and/or how to get this to work properly will be much appreciated!

    On another note: if I chose the url+referrer option with the 'do nothing'-action: why do I still get the matched/unmatched boxes ? Feels kind of illogical.

    N.B.: I found the following post with the same question on the old UrbanGiraffe support forum. Unfortunately, there is no reply nor solution to be found there.

    Spring greetings,
    Juliette

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Redirection
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic