Support » Plugin: Widget Logic » HOW-TO: Hide Widget When User IS Logged In

  • Resolved lenwbrown

    (@lenwbrown)


    This is not a support question, but a helpful answer for others if you’ve had the problem I was encountering:

    My blog reads like a story and visitors to my blog who are NOT logged in will see a message at the top of any blog entry they access that they should begin with my first blog entry and read them sequentially, like it’s a story.

    For users who sign up, this message is invisible.

    All I had to do was add a checkmark next to

    Add 'widget_content' filter

    at the bottom of the Widget Admin Page, then open the widget that displays the message at the top of each blog entry, and in the new

    Widget logic:

    field below the widget content, I added:

    !is_user_logged_in()

    and saved the widget. The exclamation mark at the start of that logic statement indicates that the widget will display if the user is “not” logged in. If the user is logged in, this widget is hidden from the user.

    Hope this helps others!

    http://wordpress.org/extend/plugins/widget-logic/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor alanft

    (@alanft)

    The above should work without the step that activates the ‘widget_content’ filter.

    Also, a little plug for the ‘other notes’ section of the plugin pages – as this is one of the examples given

    http://wordpress.org/extend/plugins/widget-logic/other_notes/

    Oh? Without activating the filter at the bottom of the Widget Admin page, the filter text area is invisible on all my widgets. I had to activate it first by placing a checkmark and saving, which I read on the plugin readme file.

    Thanks for this plugin too, by the way! I’d spent the past three days trying to figure out a solution to my particular issue until I came across your plugin. I can’t understand why so many people have given in only 1 star. It well deserves 5.

    Thanks again!

    Plugin Contributor alanft

    (@alanft)

    “Without activating the filter at the bottom of the Widget Admin page, the filter text area is invisible on all my widgets. I had to activate it first by placing a checkmark and saving, which I read on the plugin readme file.”

    you really shouldn’t have to. do the widget logic text boxes go again if you untick and save? i really hope they don’t

    glad it’s all good of course!

    Ahhhh, I discovered that I was on the widget page when I initially activated your plugin (on a second tab in Chrome) and had not refreshed the widget page properly.

    Ticking and unticking and saving both times made me realize my error in that regard. the logic text box was there either way.

    So it was a matter of me not refreshing the Widget Admin contents at the proper time.

    You are correct. 🙂 I was going to remove that part of my directions in my first post on this thread but now it appears the “edit” button is missing.

    EDIT: it appears editing old posts is only permitted for a certain time. I’ve edited up to about an hour after posting here. Good to know as well that I need to be quick or else my words are written “in stone” as it were. 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘HOW-TO: Hide Widget When User IS Logged In’ is closed to new replies.