Support » Plugin: WPS Hide Login » How to hide “This has been disabled”

  • Resolved Kurnik

    (@kurnik)


    Hi,

    Can you please help me how to hide “This has been disabled” page I’m getting from when I have start using your plugin and change wp-admin login. I don’t looking for solution that nobody will know that I’m using WordPress just don’t want to have this ugly WP page there.

    Would be really happy to solve this one out.
    Thanks.

    Cheers 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • Agreed, it would be good to be able to respond with site’s 404 page.

    Would be much better by using a redirect to home url or simple 404 page. Pleas add this!

    I’ve edited the script to simply redirect to the home page defined in WordPress rather than display this message.

    To do the same (or change the message that is displayed), simply edit the /wp-content/plugins/wps-hide-login/wps-hide-login.php file and search for the following (at lines 391 and 400 as of this post):

    wp_die( __( 'This has been disabled', 'wps-hide-login' ), 403 );

    and replace both occurrences with:

    wp_redirect( get_home_url(), 301 ); exit;

    Or you can chose to edit the This has been disabled text as you see fit.

    Hope this helps 🙂

    • This reply was modified 1 year, 6 months ago by  ouija.

    Thanks ouija 🙂

    That was very helpful 🙂

    I’ve edited the script to simply redirect to the home page defined in WordPress rather than display this message.

    @ouija: The only problem is, that this is not update proof.

    Plugin Support Benoti

    (@benoti)

    Hello,

    Now the new version of the plugin shows a 404 page not a 403 😉

    Best regards

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘How to hide “This has been disabled”’ is closed to new replies.