Support » Plugin: FSM Custom Featured Image Caption » How to hide captions on the front page?

  • Resolved kseniam

    (@kseniam)


    Hi,

    I have a question concerning the captions on the front page (using FSM Custom Featured Image Caption Plugin).

    I need not captions at the previews of the posts on the front page.
    I need to have the captions, however, in the post itself.

    How to do this?

    With my best regards,
    Ksenia.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Fesomia

    (@fesomia)

    Hi! With regular themes, usually, the captions are not showed on the front page. Which theme are you using? Can you share some public link to take a look deep into your problem?

    Thanks for using the plugin 🙂

    Hi,

    thanks for the quick reply!

    I use the “himalayas” wordpress theme.

    Please, have a look at the links below

    Front page is here
    https://klassenreise-leipzig.de/#Unterkuenfte

    The first picture from the lect contains a caption (“Schlaf Gut Leipzig @ Klassenfahrt nach Leipzig”) that I wish to hide on the front page.

    The post is here
    https://klassenreise-leipzig.de/pension-schlafgut-leipzig/
    Here the caption should remain, it is OK for me.

    Could you please advise me what to do?

    Best,
    Ksenia.

    Plugin Author Fesomia

    (@fesomia)

    It seems you are using the Front Page Sidebar widget included with Himalayas to show some featured posts or pages, right?

    You can add a special CSS style to hide the captions from all the widgets in your site:

    .widget .wp-caption-text {display:none;}

    Add this code in the “Additional CSS” box, in the WordPress theme customization section, and tell us if the trick has worked.

    Many thanks !!!

    Plugin Author Fesomia

    (@fesomia)

    Glad to help you, @kseniam

    You can leave some stars at https://wordpress.org/plugins/fsm-custom-featured-image-caption/#reviews, it will help us a lot! 🙂

    Hi @fesomia,

    I’m having this same issue too on my staging site (not live yet) following the most recent plugin update, but only if I use a custom CSS style (which I happen to be using…). I’m not using any sidebar widgets, unlike @kseniam.

    So, the solution, for now, is not to use any custom CSS style, but this is not ideal as the default caption size, font, color, etc, don’t quite match my theme’s fonts….

    Is there any other way to circumvent this?

    Thanks!

    Eva

    Plugin Author Fesomia

    (@fesomia)

    Hi @ecabral. Are you working with the Himalayas theme, too? Tell us which theme are you using, we will try to take a look into this specific issue.

    Hi @fesomia,

    I’m working with this theme:

    http://eris-shop.tkdemos.com/

    thanks!

    Plugin Author Fesomia

    (@fesomia)

    @ecabral, which method are you using for listings posts or pages in the homepage? A portfolio plugin, a specific template page, a shortcode, a particular configuration in your theme…? Are you listing pages or posts?

    I hope you understand that it is difficult to get an idea of the problem with such limited information and without being able to inspect your website directly 🙂

    Hi @fesomia,

    I’m using a portfolio which is native to the theme. You can see the live site at https://goo.gl/wMa2Bg to get an idea.

    However, mind that I have no issue here (yet?). I’m using FSM Custom Featured Image Caption v 1.13 and a slightly different theme http://eris.tkdemos.com/, instead of http://eris-shop.tkdemos.com/. Where I do have the issue is with this latest theme and FSM Custom Featured Image Caption v 1.15.

    Thanks!

    Plugin Author Fesomia

    (@fesomia)

    We think we got it. Definitively we have to study these kinds of cases more in deep in the next days!

    Meanwhile, can you test this code in the additional CSS box? (following the same indications in https://wordpress.org/support/topic/how-to-hide-captions-on-the-front-page/#post-10564295)

    .home figcaption {display:none;}

    With this, all the captions on the homepage should be hidden. Tell us if has worked while we look for a more global solution.

    Hi @fesomia,

    using the CSS you sent in addition to the custom CSS I was already using doesn’t hide the captions from the front page. Only zero CSS on the ‘Custom Style’ box will prevent the captions from showing on the front page.

    Thanks!

    Plugin Author Fesomia

    (@fesomia)

    Hi there, just to let you know that latest (1.16) release corrects some problems detected when showing a list of posts and allows you to enable / disable the image caption in lists (disabled by default)

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘How to hide captions on the front page?’ is closed to new replies.