WordPress.org

Forums

[resolved] How to have site at www.mysite.com and blog posts appear at www.mysite.com/blog (6 posts)

  1. csbarrett
    Member
    Posted 5 years ago #

    I've searched all over the place for help on this and tried a few things with no luck, so I thought I'd try my first post here.

    I installed wordpress in my root directory so I could use it as a CMS for my site. I created all my pages and set "Home" as my Front Page and "Blog" as my Posts page.

    The posts come to the blog page correctly, but the URL is http://www.mysite.com/?page_id=315. I want to make it so the URL for the blog posts is http://www.mysite.com/blog and I am having no success!

    If I just change the blog URL in settings > general I get login errors. I had to edit the database in phpMyAdmin to fix it. I saw a number of forum threads on the same subject point to this codex post on giving wordpress its own directory, but I'm not concerned with having the core wordpress files in my root directory. That post doesn't address the problem. I don't think the permalinks settings is the solution either because there doesn't seem to be a way to make a custom permalink for one page.

    Any ideas? Is it possible to make my posts come to a URL like http://www.mysite.com/blog when wordpress is installed in the http://www.mysite.com root directory?

    Thanks!

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    In Admin/Settings/Permalinks, try setting the optional category base to blog.

  3. csbarrett
    Member
    Posted 5 years ago #

    That didn't seem to change anything. The URLs are all the same still, and when I go to http://www.mysite.com/blog I get a file not found error message.

  4. Steven Jones
    Member
    Posted 5 years ago #

    Create a new page called Blog.

    Then go to settings >> reading

    And set the posts page to "Blog". That should do it.

  5. esmi
    Forum Moderator
    Posted 5 years ago #

    Ok - let's re-think...

    Delete the optional category base. Then try setting up a custom permalink structure in Admin/Settings/Permalink. Use one of the default options for now.

  6. csbarrett
    Member
    Posted 5 years ago #

    Thanks rainemaida, that redirects the blog posts but it doesn't clean up the URL. I've already got it set to "Blog."

    Esmi, you are blessing! I just selected the "Day and Time" permalink option and all my pages are now accessible by their title. I feel silly for not trying that before, but thank you for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic