• We need our media files to be uploaded into the default WP folder locally (wp/wp-content/uploads) but the Cloudfront CDN does NOT need this path as it’s automatically picking up the files from that origin server path (s3-bucket/wp/wp-content/uploads).

    So, while the local actual path will be:

    The CDN actual path should be:

    The challenge with this plugin is that the above situation cannot be implemented.

    1. If I set the Path to empty, and save settings, the Path is turned off. (In Help, it tells me that this path is for CDN and is not connected to the local path, but this is untrue).
    2. If I set the Path to the default wp/wp-content/uploads, then the CDN path is also forced to this prefix URL. So it becomes https://ourdomain.com/wp/wp-content/uploads/2019/01/9999/1.jpg, which is not what we need. We need the folder on the CDN side to be empty.
    3. If I set off the Path and turn this option totally off, it works as option 1 above.

    Very frustrating. What should we do, and how should we make sure that the older media URLs match the new CDN ones? That’s the only task this plugin is supposed to perform and it does NOT perform it. Much appreciate any pointers.

Viewing 1 replies (of 1 total)
  • Plugin Contributor ianmjones


    1. WP Offload Media Lite’s “Path” setting really does not have any bearing on the local path, that path is determined from WP’s settings and WP Offload Media Lite does not effect that at all.

    2. Just turn off WP Offload Media Lite’s “Path” setting, save changes, and any **new** Media Library items will be offloaded to the root of the bucket, or year/month based path if that’s being used.

    3. Not quite following what you’re saying here?

    4. As per my answer to your previous question, to change the path of already offloaded objects, you need to remove them from the bucket and re-offload them to the new path, ensuring WP Offload Media is aware of the changed path.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.