WordPress.org

Support

Support » Plugins and Hacks » [Resolved] How to Get Google to Not Index Pretty Links? Analytics Shows urls Can't Be Found

[Resolved] How to Get Google to Not Index Pretty Links? Analytics Shows urls Can't Be Found

  • lindaloustarr
    Member

    @lindaloustarr

    Hello 🙂
    How do I get Google to not index the pretty links? When I go to my webmaster analytics it shows “all” the pretty links as can’t be found, which of course is creating a backlash of 404 errors as far as google is concerned, I looked at my xml-sitemap plugin to see if pretty links shows up to exclude but it doesn’t, would I “have to use no follow” or? Site is http://breathepossibility.com I would prefer not to have to use no follow if at all possible . . .

    Your assistance is greatly appreciated, thank you.
    Peace & Blessings to All
    Linda Lou

    http://wordpress.org/extend/plugins/pretty-link/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Blair Williams
    Member

    @supercleanse

    This shouldn’t be happening in this way … Google should be able to follow redirects. If you’re having problems with this you should check the no follow option on your pretty links though … it will pass a noindex in the http header to googlebot when it crawls your site.

    Jan
    Member

    @janestromsoddgmailcom

    This is a problem for me as well. Google is in fact indexing a lot of our prettylinks. Using nofollow is not recommended:

    Friends Don’t Let Friends Use NoFollow

    I would like a noindex option, but that currently is not available. Also, I would like to be able to apply the noindex to previously created links.

    Jan
    Member

    @janestromsoddgmailcom

    lindaloustarr,

    If you make your links 301 instead of 307, I believe Google will eventually remove them from their index.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] How to Get Google to Not Index Pretty Links? Analytics Shows urls Can't Be Found’ is closed to new replies.