WordPress.org

Support

Support » How-To and Troubleshooting » How to fix browser problems

How to fix browser problems

  • Hi, How can I solve the browser problem. My site is ok in Firefox, but not in Internet Explorer. can someone help me with this issue?

    Warmest regards,
    Kris

Viewing 15 replies - 1 through 15 (of 25 total)
  • I have the same problem but no one seems to have an answer. I may just have to switch to a different blogware.

    Hi, I have the same problem only in Firefox. It happened just recently, where it’s as though the screen view shifted a few cm to the left, and now a key design element is cut off from view. This is only on Firefox. It used to be fine, but now it’s not. I also checked with Safari and IE, and the screen view is fine. So a similar problem… i’m hoping if someone can respond to our thread, we can all get an answer… thanks.

    Hi, I found this link, it checks out all errors on your site. Iยดm checking it out now myself and it shows lot of errors on my site.

    regards,
    Kris

    VincentvandenHeuvel
    Member

    @vincentvandenheuvel

    W3C validator is every nice tool for creating validating HTML but it doesn’t guarantee in any way cross browser compatibility. Internet Explorer is notorious for it’s incompatibilities. Unless you’re aware of browser quirk modes and css hacks???

    Regards,
    Vincent

    the_doctor199
    Member

    @the_doctor199

    Im just after spending a few hours changing lots of things around on my website and it looks great in Firefox, tried it in IE and it looks totally wrong – the main issue being that the text is appearing huge, does anyone have any ideas?

    The site is: http://www.shoottothrill.co.uk

    S.K
    Member

    @kichu

    the_doctor199,

    Add this to the header.php of your theme above </head>:

    <!–[if IE]>
    body{
    font-size: 80%;
    }
    <![endif]–>

    (Change the percentage by trial and error)

    HTH

    S.K

    the_doctor199
    Member

    @the_doctor199

    Kichu, just tried that and it hasn’t changed anything. I tried entering values between 20 and 80 and nothing changed.

    esmi
    Forum Moderator

    @esmi

    No! Don’t change the body font size! That’s really bad practice (and yes – I know the default theme does – what can I say). Find the problem first and then change the font size on that specific block/element. Right now, you have a body font of 20% set in IE which frankly, is ludicrous! I can guarantee that such a setting will come back and bite you.

    Despite what was said above, start by sorting out the validation errors on your site. It won’t cure every problem but it does provide the best possible foundation for cross-browser performance. For example, your meta-keywords are totally screwed up…

    S.K
    Member

    @kichu

    First check by reloading, after flushing cache in IE.

    I think the problem is pronounced in your menu. Try changing the font-size declaration for “#menu ul li” alone in the conditional styling, fixing specific values in terms of px.

    S.K

    the_doctor199
    Member

    @the_doctor199

    Esmi, it should now be at 80%. Im just working my way through that list of problems now, I think I have sorted out the keywords though.

    Kichu, I tried changing the value in the “#menu ul li” on the stylesheet and it hasn’t changed the performance in IE unfortunately.

    S.K
    Member

    @kichu

    In IE, your menu tends to float to the left as per your stylesheet declaration. in the theme, the default setting is float: right which works fine in IE.

    Try changing the float attribute of the menu to right and text-align: right.

    Hope it will get you good sleep! ๐Ÿ™‚

    S.K

    the_doctor199
    Member

    @the_doctor199

    No luck with that Kichu, the menu is still appearing huge in IE. Checked it out in Opera and it looks fine in it, so it’s only IE that it is messing with it!

    Any other ideas I should try?

    S.K
    Member

    @kichu

    Beats me, indeed!

    I even tested with your stylesheet on my localhost installation and it works perfectly in IE.

    Now before I try to dwell deep into it, pl tell me whether you made any hack for the current page item for “home” in the functions.php.

    Or any other extra hack on the theme files?

    S.K

    the_doctor199
    Member

    @the_doctor199

    Yeah, I had two “home’s” listed as I had a static page as my homepage so this was bringing up two homes so I was advised in another thread to remove one of them, does this affect it?

    (Thanks for your help, i know very little about the coding side of things! ๐Ÿ™‚ )

    S.K
    Member

    @kichu

    I find that you seem to have made some changes to the page.php. I can’t find the footer and the html is truncated; may be one or a couple of closing div tags are missing.

    I think you had tried to remove the calls to sidebars but removed the footer call also.

    To make the long story short, add the following to the end of your page.php:

    <?php get_footer(); ?>

    Try it and see.

    S.K

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘How to fix browser problems’ is closed to new replies.