Support » Fixing WordPress » How to fix "An error occurred while updating…" "Could not create directory"

  • There are quite a few threads where users report the following error when trying to automatically update a plugin:

    An error occurred while updating… Could not create directory… /wp-content/upgrade/plugin.tmp

    There a few replies.

    If I change the permissions on /wp-content/upgrade to 777 or 2777 nothing changes. My hosting provider has also had a go at this and nothing changed again.

    What needs to happen to fix the permissions?

Viewing 7 replies - 1 through 7 (of 7 total)
  • no one knows how to fix this?

    Searching around a bit, looks like it could be various issues. Have you tried disabling your other plugins to test if its a plugin problem?

    I have raised a ticket with trac for this, the answer so far has been that it is a server issue, but some plugins update and some don’t.

    What has happened in my case is that by using ftp after the failure I can still see a folder that could not be deleted, this cannot be renamed via ftp or written to.

    In about 20 – 30 minutes this folder vanishes and I can add the plugin back, this also happened with the twenty eleven theme upgrade, so I am sure it is the WordPress update function that is causing this file locking.

    I also have a topic open for this in the forum.

    The forum responses tend to ignore what you write and leap to the defence of WordPress, the upgrade process has always worked for me, until the WordPress 3.2 version release.

    My ISP has said that nothing they are aware of has changed on the server to lock the folders or files and the updates should work ok.



    It may be a plugin problem, but that would imply that plugins have the ability to mess with the permissions of the /wp-content/upgrade folder, which I find doubtful.

    I have another WordPress site, which has had 3.2 and 3.2.1 installed, and it has never had a problem installing any upgrades.

    The problem WordPress installation has problems installing ANY plugin or theme, not some.

    This leaves us with the conclusion that it a server issue, probably permissions related, but it is odd that my host’s tech support cannot find anything wrong on this front.

    Mine is on a windows server, never had an issue before now with auto updates, however there have been a lot of updates, js, php as well as WordPress, it could be a specific combination fails.

    One of the devs has been kind enough to have a look at a test website I have, so I will report back when I hear.


    I think I may have found the problem, if you are on a windows server that offers WinCache.

    Have a read of this post.

    My host runs Apache, not Windows, and they have comfirmed the permissions on the affected website are the same as those of an unaffected WP installation I also manage.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘How to fix "An error occurred while updating…" "Could not create directory"’ is closed to new replies.