Support » Plugin: Fast Velocity Minify » How to exclude EDD checkout forms from caching ?

  • Resolved laymonk

    (@laymonk)


    Hi,

    I have been using EDD along with FVM for a while now. I recently configured EDD’s recurring payments module, and created some recurring payment products.

    However, I find that with FVM enabled, the checkout form does not display for recurring payments. I created a support request to EDD Support and they suggested I exclude EDD’s checkout forms from FVM caching.

    My puzzle is why this same issue is not affecting EDD’s standard products, but only the recurring payments.

    Any suggestions on how I can keep using FVM, along with EDD recurring payments ?

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Raul P.

    (@alignak)

    I haven’t looked into it, but you need to open the google chrome console log and go through the process, while paying attention to the console log.

    There should be some error in red, when you perform certain action.
    A developer will be able to see where the conflict is and add it to the ignore list.

    Unfortunately, it’s not straightforward if you are not a developer or advanced user, so I suggest hiring someone to help you see what is the problem on EDD and what to add to the FVM ignore list.

    If that happens inside logged in pages, you can enable the fix page editors option.
    If it’s on some anonymous page where people are not logged in, and if it’s just a specific page where that happens, you can also disable FVM completely only on that page.

    This is still a job for an advanced user or developer, though you can try if you can read and understand the code.
    https://wordpress.org/support/topic/disable-fvm-on-a-single-page/

    laymonk

    (@laymonk)

    Thank you for responding @alignak

    I am enough of a ‘developer’ to understand about browser developer tools, and I did see the errors on the console. I will follow through and try to identify the direct path to the javascript file that is shown in the console.

    The challenge I have is that the page I am visiting is dynamically generated, which is why I am asking about exclude patterns, but I guess getting the full path to the script(s) with errors will be fine.

    You have pointed me to a URL that seems to suggest I need to use php code to exclude FVM on specific pages … is this right? There is no config section where exclusions can be specified ?

    Thanks again.

    Plugin Author Raul P.

    (@alignak)

    The ignore list is for specific exclusions during merging of specific js files. It doesn’t stop anything on specific urls.

    The url I provided, gives you an option if you want to completely disable FVM on one specific page.

    This is not the same as the ignore list.
    The ignore lsit is for merging conflicts only.

    https://wordpress.org/plugins/fast-velocity-minify/faq/

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘How to exclude EDD checkout forms from caching ?’ is closed to new replies.