Support » Plugin: Advanced Post List » How to exclude all Pages and only show Posts

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author EkoJR


    If you want to display all the post/pages from a certain post type, then all you gotta do is select the Any/All checkbox within the taxonomy tab, and it should display all terms within that taxonomy and post type. To display all post from the post type, then just check Any/All for all the taxonomies within that post type.

    Hi EkoJr

    I have the same problem, but I don’t understand your reply!

    New install of plugin. Created my own preset, but this works OK. Problem is with what posts are selected. I want posts, but not pages listed.

    If I have nothing selected in either Post or Page taxonomies, I get all posts and all pages listed. So I want to prevent Pages being listed, how do I do this?

    In general, I find the usage of these taxonomies extremely confusing! In the Category tab, if I select nothing, it seems to list everything. If I select Any/All, it seems to list none of them. Is this an include or exclude filter? I cannot get my head round the options at the top:

    Require Taxonomy within post_type.
    Require Terms selected.
    Include Terms according to current page.

    I’ve been playing with them trying to fathom them out, but have failed so far.

    For example, if I select the first option (Require Taxonomy within post_type.) and click Save preset, I get the following error:

    “Error: If you selected ‘Require Taxonomy’ you must select ‘Include’ and/or select at least two terms. If the current page does not have any terms in this taxonomy. The post list may not display anything.”

    Are the Any/All and the list of Categories below the dividing line the ‘Terms’?

    I’m confused.

    If I want to exclude all pages, what do I do? If I click on ‘Page’ and then ‘Select parent’, I get a list of the pages. By default, they are all unchecked, so why are they appearing in the list? If I click on ‘Check all’, all six pages are ticked, but only two pages at a lower level are listed and the four top-level are not.

    If I do that and have the select page box open, I cannot close it – the close box does nothing and if I click on the Post taxonomy, this box sits over the top and I can’t see underneath it. This is in both Chrome and Firefox. I have to reload the page and the Preset to continue. Is this a known issue?

    No doubt there is a logic to all the settings, but I just can’t see tham at the moment!

    Any help you can give, greatly appreciated.

    I want to display posts only or pages only, and find the taxonomy panel confusing too.

    Using trial and error, I can list only posts if I check on all the Categories (excl Any/All), and check off all the Tags. If I had more Categories than Tags, I’d do it the other way round. Thankfully I don’t have many Categories (at the moment). But shouldn’t I be able to just check Any/All?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘How to exclude all Pages and only show Posts’ is closed to new replies.