Support » Plugin: WP Super Cache » How to Exclude a page from being Cached

  • I want to exclude a page from WP Super Cache from being cached infect I install a private messaging system but this plugin is creating problem, when I contact to owner of this plugin, they advised me to exclude that page from being cached, so how can I exclude any particular page.

    Regards

Viewing 1 replies (of 1 total)
  • I just checked and it’s possible that Front End PM (I’d guess that’s plugin) uses auth cookie (which isn’t added in WPSC cookies). It seems as reason why Don’t cache pages for known users doesn’t work as should. There is fix for this issue – PR 631.

    I think that the best is to you add following PHP code:

    add_action( 'fep_template_redirect', 'my_fep_auth_redirect' );
    
    function my_fep_auth_redirect() {
    	if ( ! defined( 'DONOTCACHEPAGE' ) ) {
    		define( 'DONOTCACHEPAGE', true );
    	}
    }
    

    If you can’t do this then it’s possible to add it on WPSC Settings/Advanced tab – option Add here strings (not a filename) that forces a page not to be cached. … If string matches part of URL then cache is rejected. You should add good “rule” which matches only this page because it may reject caching of other pages.

Viewing 1 replies (of 1 total)
  • The topic ‘How to Exclude a page from being Cached’ is closed to new replies.