Support » Plugin: WP Super Cache » How to exclude 1 page from caching?

  • Hi there,

    I’m running A/B tests and I believe caching is interfering with it and just causing the “default” page to keep showing to each visitor.

    Is this the correct way to STOP this one particular page from being cached?

    I went to Settings > Advanced. Then I went to where it says “Add here strings (not a filename) that forces a page not to be cached”

    And I put the URL slug of the page to exclude.

    So if the page is “www.mywebsite.com/page-url-is-this/”

    Then what I typed in as the string is “/page-url-is-this/”

    (without quotation marks)

    Is that correct? Will that successfully stop caching that particular URL when visitors go there?

    • This topic was modified 1 year, 7 months ago by  Ronnie55.
    • This topic was modified 1 year, 7 months ago by  Ronnie55.
Viewing 2 replies - 1 through 2 (of 2 total)
  • That is exactly how to do it.

    You can prove that it isn’t being cached by viewing the source code of that page, and then go way to the bottom… if it’s cached, it will have a comment like:

    !– Cached page generated by WP-Super-Cache on 2018-04-10 20:44:37 —

    If a cached page wasn’t served, then it won’t have that. Give it a try!

    – Scott

    I am seeing an issue (on all my blogs that used wp-super-cache – which I now had to temporarily disable altogether) where I can’t add items to this exclude list anymore. I see the OLD strings. The UI makes it look like it accepts the new strings, it saves them…. but when you come back later to the admin page, the strings are gone. Of course, those pages get cached.
    I have some dynamic pages that MUST NOT be cached and this is making it impossible to exclude those pages 🙁
    Where are the strings stored/saved? in the DB?
    Is there a recent bug in this area? Does anyone else see this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘How to exclude 1 page from caching?’ is closed to new replies.