WordPress.org

Forums

[resolved] How to enable Post-via-Email? (5 posts)

  1. Michal M
    Member
    Posted 4 years ago #

    Hello Everyone,

    I'm currently running WordPress 3.0.1 MultiSite in my company. I was asked to set up post-via-email functionality, but I can't seem to find options for that.
    I've looked this problem up on Google, with few solutions that simply don't apply to my installation for some reason. I have no options to "Enable post-via-email" nor I have options to set it up in Settings > Writing.

    Any ideas?

    Thanks in advance.

  2. David Sader
    Member
    Posted 4 years ago #

    http://core.trac.wordpress.org/ticket/14171

    What multisite has disabled (wp-includes/ms-default-filters.php) a plugin in "mu-plugins" can enable:

    <?php
    	add_filter( 'enable_post_by_email_configuration', '__return_true' );
    ?>

    http://codex.wordpress.org/Post_to_your_blog_using_email

  3. Michal M
    Member
    Posted 4 years ago #

    Thank you.

  4. negfx
    Member
    Posted 4 years ago #

    Thank you I was searching this the whole time! can I edit ms-default-filters directly or with which plugin I can solve this?

  5. negfx
    Member
    Posted 4 years ago #

    I have edited the ms-defaul-filters and all the necessary fields to publish post via email however it is not working. Do I have to load /installdir/wp-mail.php?

    The emails are in the inbox of the email account and the login data is correctly entered however my multi site is refusing to get the mails. What could be done here?

    Thanks

    ***** Update
    loading wp-mail gets the posts but isnt there a way that this will happen automatically for multisites as on the normal WP?

Topic Closed

This topic has been closed to new replies.

About this Topic