Support » Plugin: Plugin Load Filter » How to enable PLF at admin bar in shop page?

  • Resolved wtvxy


    I can see the PLF icon for Plugin Load Filter status at admin bar when open admin page.
    But when I use admin account to browse my woocommerce auto-generated shop page or products page, I cannot see this icon.
    I want to debug if the plugin is activated at this page.

    I also want to know how can I know the type of each page?
    When I activate plugin for ‘page’ type, the plugin is deactivated for shop.
    this plug is activated only after I activate plugin for ‘home’ type, but shop should not be home type. It make me really feel confuse.

    • This topic was modified 1 year, 2 months ago by wtvxy.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author enomoto celtislab


    In my environment,
    The PLF icon in the admin bar is visible in the store and on the product page.
    Maybe there are too many elements displayed in the admin bar and they are hidden.

    The page type of the product page is probably ‘product’.
    The store page is probably being treated as a home page because it cannot be identified as a product archive page.

    The woocommerce site is much more complex than a normal blog site structure, so it is difficult for the Plugin Load Fillter plugin to handle it.

    There is an add-on that can do URL filtering to support woocommerce, so please consider it!

    Thread Starter wtvxy


    OK. Thank you.

    What if I want to not use some plugins and use some plugins for a single page at the same time?
    Plugin filter for Single post is only allow setting ‘use’ or ‘not use’ but seems cannot configure them at the same time.

    Plugin Author enomoto celtislab


    ‘use’ or ‘not use’ specifies whether individual filtering should be performed for that post page.

    Therefore, if you want to filter only for that post, specify ‘use’, check plugins to enable, and uncheck plugins to disable.

    Thread Starter wtvxy


    For example, I have one GeoIP direction plugin and only want to use it on my homepage. What I do first is adding GeoIP direction plugin into filter entry then go to the homepage editor and check use it.

    I installed ‘mailchimp-for-woocommerce’ and I want to not use it on my homepage. At this time, even though I add it into filter entry and checked all terms. I cannot simply not use it on the edit page of my homepage because I have already selected ‘use’ tab. Even though I unchecked ‘mailchimp-for-woocommerce’ in ‘use’ tab, it does not work to filter mailchimp-for-woocommerce and still enable it. Normally, I can simply uncheck the homepage in Page Type Activation and keep others, but shop page is also recognized as homepage which I do not want to disable for ‘mailchimp-for-woocommerce’.

    • This reply was modified 1 year, 2 months ago by wtvxy.
    Plugin Author enomoto celtislab


    For plug-ins that you want to activate only on specific pages, first set the Page Type in Filter Registration.

    For Page Type Activation, check only the page types you want to activate for that plugin.
    If you do not check all of them, the plugin will be disabled for all pages.

    If you have a specific post you want to activate that plugin for, go to the edit page of that post and set the filter to ‘use’ to check only the plugins you want to activate

    For woocommerce, etc., which cannot be fully supported by this, the URL filtering add-on will allow for more detailed support.

    If you are using the URL Filtering add-on, there is sample filtering data for woocommerce that you can load and customize to handle this. Please consider it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘How to enable PLF at admin bar in shop page?’ is closed to new replies.