Support » Fixing WordPress » how to enable oEmbed in my WP2.9-Media Settings not available…

  • i have a fresh WP2.9 installed. but not able to use the oEmbed short-code.

    in Setttings>>Media, there is no oEmbed, only “Autio-embeds” i can tick.

    please tell me if i need to add any code of something to any WordPress files or my theme files?

    many thanks in advance.

Viewing 3 replies - 1 through 3 (of 3 total)
  • What’s happening when you try to use the embed code?

    “it’s broken, why doesn’t it work?” isn’t a clear indicator of what could be wrong. please provide any and all details you can.

    hi jdingman,

    1. when I try to insert [embed]url link put to media[/embed] into my post, the short code show up in the post. so i assume the oEmbed short code is not interpreted.

    2. when I’m in the backend admin panel, go into Settings > Media I cannot find “oEmbed” section which was shown in those “how to enable oEmbed” tutorials, so I think for some reason I cannot enable oEmbed with my WordPress 2.9 installation.

    with the above 2 facts I encountered, I think may be I need to add some kind of code in function.php or anything to activate it, but I have no idea, because I’m new to this coding thing.

    If any help to point me to the right direction, much appreciated.

    I have several installs of wordpress on 2 different servers.

    Both have cURL installed and curl test scripts work properly.

    Both are shared hosting platforms (cpanel and virtualmin) with virtual hosts running PHP as user under fCGId.

    php -m shows curl running as a php module

    Auto-embed is enabled in Settings > media

    I have cleared caches, turned off wp-cache or super cache, restarted apache after 2.9 upgrades, etc. to eliminate those as issues.

    When I paste in a valid, embeddable Youtube or Vimeo URL, and save the post, the URL is saved as plain text and no auto-embed occurs.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘how to enable oEmbed in my WP2.9-Media Settings not available…’ is closed to new replies.