WordPress.org

Support

Support » How-To and Troubleshooting » how to enable lightbox in nextgen gallery

how to enable lightbox in nextgen gallery

  • just a simple question i can’t figure out for the life of me.

    i’ve enabled the next-gen gallery plugin
    uploaded pictures to a gallery
    set the options->effect to lightbox and saved settings

    I can’t tell where I insert that code it supplies with the %gallery_name% ??

    when I insert a gallery into my post it simply adds gallery=1 \

    i simply want to be able to view a gallery via lightbox in a particular page

Viewing 15 replies - 1 through 15 (of 29 total)
  • Download lightbox2 (http://wordpress.org/extend/plugins/lightbox-2/) and install it in your plugins directory and activate it.

    Be sure that <?php wp_head(); ?> is in the header.php file of your theme.

    Select the lightbox effect as you did in the nexgen options > effect page and save the settings.

    That’s it. It automatically then uses the lightbox plugin to display the images.

    This is true of all the effects. The only effect that is included in the nexgen download is the thickbox effect. The others you have to download and install in your plugins directory.

    I followed your instructions but still can’t get lightbox2 to work. I downloaded lightbox plugin and activated it. Then updated the settings on the ngg effects options page.

    The only viewer working is thickbox.

    Please post a link to your page

    Please post a link to your page

    Here is a link to a test entry with some photos.

    Firstly use this clone of Lightbox2. I promise you it’s far more lightweight:
    http://wordpress.org/extend/plugins/slimbox-plugin/

    Deactivate the plugin you’re using, and upload this one, making sure ALL the files are uploaded.

    I checked the paths of some of the lightbox plugin on your site, and they gave me a 404 error. The Slimbox plugin is an exact clone, looks the same, functions the same but is far more lightweight.

    Check it out

    Yep all JavaScript return a 404, check the path and try the recommendation from othellobloke

    Thanks Guys! That did the trick.

    But now I am wondering how to change “the key shortcuts” used for ‘previous’ and ‘next’. Looked trough the javascript of slimbox.js but couldn’t really find out where to change this. I need it to fully localize my wp installation.

    I am having a similar problem on my page. I’ve installed the Slimbox plug-in and activated it. I’ve chosen “Lightbox” under Options–>Effects in NextGen. But when I insert the code, it just shows up on the page as code rather than effect. What am I overlooking? Thanks for your help in advance!

    yes same here – u activate Lightbox under NGG settings, but then nothing happens…. How does it work?

    Have you installed Lightbox or Slimbox?

    No I installed Slimbox as suggested above. I chose ‘lightbox’ from NGG settings. I don’t know if you’re supposed to do any more to activate it… the thickbox works, and to be honest I’m not exactly sure what difference this Slimbox makes….

    For clarification, NextGEN include the Thickbox script, other effects scripts must be added by a seperate plugin to your blog :

    Here you can select the thumbnail effect, NextGEN Gallery will integrate the required HTML code in the images. Please note that only the Thickbox effect will automatic added to your theme.

    yeah we know 🙂 But your instructions are not clear on how you activate the other effects (after they have been installed). For example I installed Slimbox and activated it in the NGG Settins but I don’t get any effect when I click on a thumbnail….

    How does the HTML Source look like? You see any reference to lightbox in your img tags? How does the header reference to slimbox.js resolve? Just post your URL if you’re unsure.
    Personally I use Thickbox, Slimbox gave me to many javascript errors.

    Post a link, that would be the best

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘how to enable lightbox in nextgen gallery’ is closed to new replies.