Support » Fixing WordPress » How to Enable Comments on a Page

  • Resolved proudtobedad

    (@proudtobedad)


    Hi there,
    I’m using Modularity Lite as my theme. I’m trying to enable comments on the pages (already works on the posts) but am having an issue.

    A prior post on the topic suggested adding the following code into my page.php:
    <?php comments_template(); ?>
    I added it, but it is not working. Do I need to remove the line below it, or do I have it in the wrong place?

    Currently, the page.php reads as:

    <?php comments_template(); ?>
    <?php if ( comments_open() ) comments_template(); ?>

    Any ideas? I’m new to coding so want to make sure I don’t mess this up! 🙂

    Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • esmi

    (@esmi)

    Forum Moderator

    Just use <?php if ( comments_open() ) comments_template(); ?>

    Thanks, but there still are no comments enabled on my pages. Is there something else I need to do to enable?

    Add: What’s weird is that SOME pages, like my gallery page, has comments enabled on it, while other pages don’t. Is there some kind of setting I’ve missed???

    Any help would be appreciated!

    kerganedwards-stout.com

    esmi

    (@esmi)

    Forum Moderator

    Is “allow comments” in the Discussion tab of each Edit Page ticked? If you don’t see the Discussion tab, click Screen Options on any Edit Page and tick Discussion.

    Okay, I’m stupid! I was wondering why some where showing and others weren’t!

    That did it. And here I was, thinking it was the code!

    Many thanks!

    Thank you so much !!!It might change a lot of things for me 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘How to Enable Comments on a Page’ is closed to new replies.