Support » How-To and Troubleshooting » [Resolved] How to enable comments?

[Resolved] How to enable comments?

  • I’ve recently created a new site at http://www.ohiocichlid.com, and would like to allow people to leave comments. If I check under ‘manage pages’, I can see that ‘allow comments’ is ticked on each and every page, but still there is no option to leave comments. What am I doing wrong? I thought comments were enabled by default?

Viewing 15 replies - 1 through 15 (of 19 total)
  • admin – settings – discussion

    Many thanks – I checked there and ‘allow people to post comments on the article’ is enabled. So that doesn’t seem to be the problem. What else could it be?

    check each post individually I suppose to see if they are enabled

    I don’t have posts, only pages. On each and every page ‘allow comments’ is enabled. The whole thing is a bit of a mystery to me, especially since I am also running another site (www.fmueller.com) and there comments work just fine.


    can you supply a link?

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    Most themes don’t have the comments code on Pages by default. You’ll probably need to alter the theme’s page.php file to add the comments_template call.


    I am using the default theme.

    Otto42 pegged it
    you will need to grab the code from the theme’s single.php and add it to the theme’s page.php
    always backup 1st

    That did it! Many thanks. In case anybody else of experiencing the same problem, the code that needs to be inserted in page.php is:

    <?php comments_template(); ?>

    THIS IS THE MOST EXCITING post I’ve read! IT WORKED, IT FRIGGIN WORKED! I have some post pages and some pages pages and I couldn’t get comments on the pages. That little bit of code worked! My gosh, I LOVE YOU Samboll and fmeuller!

    I am having the exact same problem but I have a stupid question….
    Where do i find the page.php to put the code into?
    Sorry and thanx~!

    After a week of tearing my hair out, I, too, declare my undying love for Samboll and fmeuller!

    I too have the same problem and being a newbie I need detailed instructions on how to do this. I have managed to make changes to other files with peoples help so I am not entirely hopeless. I khnow cPanel a bit and can find *.php files, open them, copy and paste etc. I would appreciate a little help. I am on MSN if that helps. uncdon1114@live.com

    grab the code from the theme’s single.php and add it to the theme’s page.php

    I am unable to find either of those. Can you tell me where they are located? I am using WEb2_11 theme.

    Thank you.

    I found it. I was going thru cPanel when I should have been using the admin page. I was able to resolve the problem. Thanks!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] How to enable comments?’ is closed to new replies.