Support » Fixing WordPress » How to edit front page url

  • I have WordPress installed in its own folder and have got it running as if from the root. Everything seems to be working fine except the front page is not showing when accessed from menu or fron the url:

    Could someone tell me what I may have done wrong? How can I edit the front page (welcome page) url? Currently the front page is showing the right url when I hover over the link on the menu bar, but it then goes to skyechooks/wordpress which is wrong.

    I can edit the page from the dashboard, but not the url?


Viewing 15 replies - 1 through 15 (of 15 total)
  • I’m not encountering this problem when visiting your site. I think you’ve fixed the problem! Trying clearing your cache and check the site.

    Hey Earthylad, great site/blog!
    If I tell you about the typo (top right, two ‘i’s’ in ‘keeping!’ will you tell me how you got rid of that darned hard-coded ‘Home’ link – PLEEESE!

    All the best

    The problem is not fixed at the moment. I’ve tried several browsers and all show the ‘Welcome’ page as not found 404. It does exist as I can edit the page from the Dashboard, but I can’t edit the url?

    I should that the front page ‘Welcome’ page is a static page.

    Thanks for spotting the typo! The ‘Home’ link is not hard coded as far as I can tell. The front page can be loaded into the dashboard and edited accordingly. Just load the page as if to edit the text etc., you can then edit the title at the top. I’m assuming that your homepage is a static page.

    The link to the welcome page just links to your homepage. Is the page that you’re referring to “welcome” here is the “Welcome to Skye Chooks” page on your site then – I don’t think you can edit its url, as its being used as the frontpage.

    Yes I know I can’t edit the url on the front page, I just want to stop the 404 error. Any ideas?

    I don’t see any 404 errors, mind linking me to them?

    This is getting very strange. Whenever I try to view the ‘Welcome’ page all I get is a ‘can’t be found’ page and the offer to try searching for the page. Well I tried the search box on the ‘can’t be found’ page and yes a snippet of the welcome page appears. When I click the ‘continue reading’ link just underneath the snippet it returns to the ‘can’t be found page again, the link on the ‘continue reading’ is which when clicked can’t be found.

    I’ve got permalinks set up as custom as below:


    General Settings:



    When I do that I still don’t get any 404 pages

    Hi Darren, Thanks for your patience. I had a friend check the front page and yes, you guessed it, he sees the page perfectly well too. Many thanks for sticking with it!

    As for why Admin can’t see it, not that bothered and don’t really want to go there.

    Thanks again.

    No problem!

    Try clearing your cache, maybe thats the issue. Try browsing your site while logged out too – this’ll help narrow down that problem

    I’ve tried browsing whilst logged out and yes I see the page fine. Contrary to what I said earlier, I now would like to know why I don’t see the page when logged in? Anyway I know that visitors can see it thank goodness!

    Have you got this resolved yet?

    No not really. I still get a 404 when viewed with certain browsers, might be a cache problem. As stated earlier, if I use a browser I don’t normally visit the site with, all is well.

    Finally got this resolved by clearing cache. It now works as it should. Many thanks for imput, appreciated!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘How to edit front page url’ is closed to new replies.