Support » Plugin: Polylang » How to edit content in WordPress and the Polylang – plugin? – with demosite

  • hello dear experts, hello dear user, hello dear developer,

    the question; How to edit content in WordPress and the Polylang – plugin?

    first of all: i love PolyLang for its powerful features and the versatile options of customization. Perhaps i have overseen some things – but at the moment i struggle. i set up a site with several langauges – which is in a beta mode: at the moment i have only little text-chunks in German and English…

    what makes me wonder: both languages (texts) are visible at the same time in the menu – the german and the english text

    btw: default is German

    if i add in the Polylang-controll field a new translation the this will create a new entity in the db – and the funny thing it is imitiately visible at the top menu – why is this so !?

    see the following:
    – german: http://www.job-starter.com/?page_id=75 :: JOBS & CHANCEN IN DEUTSCHLAND
    – english: http://www.job-starter.com/?page_id=157&lang=en :: JOBS & CHANCES IN GERMANY (ENGLISH)

    see the page: http://www.job-starter.com – which is a truely beta-beta-page: and have a close look at the menu. – here you see both languages. This is somewhat disturbing and irritating – making me feel annoyed

    question: how to surpress the behaviour that both (!!!) languages are visible in the menu.

    look forward to hear from you

    regards say

    ps; Keep up the great work – it rocks and PolyLang is generally a really powerful plugin – very very flexible and versatile.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Chouby

    (@chouby)

    Hello,

    Maybe you checked the option: “Automatically add new top-level pages to this menu” which would explain why your new pages are automatically added to the menu.

    You must create one menu per language and assign it to the correct location (Polylang creates one location per language). See: https://polylang.pro/doc/create-menus/

    Hello dear Chouby,

    first of all: many many thanks for the quick reply. i am very happy to hear from you.

    Maybe you checked the option: “Automatically add new top-level pages to this menu” which would explain why your new pages are automatically added to the menu. You must create one menu per language and assign it to the correct location (Polylang creates one location per language). See: https://polylang.pro/doc/create-menus/

    you were right: exactly this was the issue: i really have made the wrong customization in the menu-settings:

    cf: `
    Menu Settings
    -> Auto add pages
    -> [checked] Auto add pages Automatically add new top-level pages to this menu`

    see the menu-configuration, that i have: at the moment:

    "Top Menu DeutschTop Menu EnglishTop Menu EspañolTop Menu FrançaisTop Menu PortuguêsTop Menu ItalianoTop Menu Ελληνικά"

    and see this – setting detail:

    
    
     Top Menu Deutsch (Currently set to: Main)  
     Top Menu English (Currently set to: Main)  
     Top Menu Español (Currently set to: Main)  
     Top Menu Français (Currently set to: Main)  
     Top Menu Português (Currently set to: Main)  
     Top Menu Italiano (Currently set to: Main)  
     Top Menu Ελληνικά (Currently set to: Main)
    
    

    note: i have to correct all these settings…

    Above all – and generally spoken: i am very glad that you have postet this answer: it helps me. I will look at all the hints that are poste here.

    You have to create a menu in Appearance > Menus for each language. See more here: https://polylang.pro/doc/create-menus/

    ❶ You have to create one menu per language and save them.

    ❷ Under ‘Menu Settings’ assign your menus to the relevant theme location, for example ‘My English Menu’ to ‘Primary menu English’ and ‘My French Menu’ to ‘Primary menu Français’.
    ❸❹❺ You have the possibility to add a language switcher anywhere in a menu. If you don’t see the language switcher metabox, check that it is not disabled in the screen options.

    Note that the language switcher will display a language only if at least one post or one page has been published in this language.

    ❻❼ Before adding your menu items (pages, categories…) to your menu, we recommend you to activate the admin language filter, available in the admin bar on top of the screen, with the same language as your menu. This way, you will be sure to add your content in the right language. Note that you must select the right item in the right language to get the right link.

    again – many thanks – i am so glad.

    above all: this support forums are very very powerful and a place for all knowledge-exchange things regarding wordpress and plugins ..

    this is the one of the best places on the whole net.

    keep it up 😉

    • This reply was modified 3 months, 3 weeks ago by say_hello.
    • This reply was modified 3 months, 3 weeks ago by say_hello.
    • This reply was modified 3 months, 3 weeks ago by say_hello.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.